WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Photos disappear when Jetpack is activated (5 posts)

  1. belphotos
    Member
    Posted 4 months ago #

    I have Jetpack 2.9.3. The moment I activate the plugin my photos are no longer viewable on my site; http://www.belphotos.me ; this is without enabling the individual components of the plugin, just the main.
    I have disabled all of my plugins, about a dozen, and then enabled them one-by-one. Jetpack is the only one that breaks the site.

    https://wordpress.org/plugins/jetpack/

  2. designsimply
    Member
    Plugin Contributor

    Posted 4 months ago #

    I tried testing one of the images on your site via Photon at http://i2.wp.com/www.belphotos.me/wp-content/uploads/2012/09/No_LF_On_Duty.jpg and I saw this returned, "We cannot complete this request, remote data was invalid"

    The Photon module in Jetpack needs to be able to access the source image before it can cache and serve it, and it looks like that's not happening for your site. You could try checking with your host to see if they're doing anything to block access to images from outside servers. Or you could temporarily disable Photon by going to Jetpack > Photon > Learn More > Deactivate in your blog dashboard.

  3. belphotos
    Member
    Posted 4 months ago #

    You have me heading in the right direction. I did not realize that Photon was automatically enabled in Jetpack. I now have Jetpack enabled with Photon disabled and the photos now display. I still have to did deeper and get it to work properly. Thanks for the help. I'll post more in a few days.

  4. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 3 months ago #

    Hi!

    Did you get this resolved with your host?

  5. belphotos
    Member
    Posted 3 months ago #

    I questioned BH about this and they do not block access to images from outside servers, unless there is an abusive condition present. That is not the case with my site. I now have Jetpack enabled with Photon disabled and the photos now display.

    For now it is resolved. I do have plans to re-link all of my photos so there is no mixup. I did this once before to resolve a similar problem when I used SmugMug.

    All of my photos reside within the site, not externally.

    Thanks for following up on this Richard, I do sincerely appreciate it.
    Bruce

Reply

You must log in to post.

About this Plugin

About this Topic