WordPress.org

Ready to get started?Download WordPress

Forums

  1. keithisleofwight
    Member
    Posted 1 year ago #

    First of all, great plugin, does everything I need.
    Unfortunately it also does things I don't need!

    My test site is http://rvyc.org.uk/wp/index.php/gallery/

    Q1. When I click on an album on the Gallery page it opens another tab with the first photo, how do I stop this happening?

    Q2. When I have closed the unwanted tab, I am then left with a box with the first photo of each album and a chance to scroll through the albums in my Picasa account, either manually or on a slideshow. By selecting the required album and clicking the cross (bottom right) I am then left with the photos in the album which will then go into the slideshow.

    Q3. Is there a way to click on a photo on my Gallery page and it starts a slideshow of that album?

    Many thanks in advance,
    Keith

    http://wordpress.org/extend/plugins/photonic/

  2. Sayontan Sinha
    Member
    Plugin Author

    Posted 1 year ago #

    To answer your questions:

    Q1: That is coming from your theme. Your theme is forcing a "PrettyPhoto" lightbox on all images. You have to talk to your theme author to find out how to prevent that from happening, as it is highjacking what Photonic does (Photonic will show you a panel with all photos in an album).

    Q2: Didn't see a question there; merely a statement of facts :-)
    As I mentioned, the panel with all the photos is what is coming from Photonic, and that is what you see in a standard demo without external interference (see http://aquoid.com/news/plugins/photonic/picasa/picasa-albums/).

    Q3: No, that is not possible. Most lightbox scripts need all images' links to be present somewhere before they start cycling through. You can, however, set up Photonic to start an automatic slideshow when any image in a set is clicked, i.e. you won't have to use the left and right arrows to move. To enable that go to Photonic → Settings → Generic Options → General Settings → Slideshow mode, and set it up to launch automatically.

  3. keithisleofwight
    Member
    Posted 1 year ago #

    Many thanks for the VERY quick reply, 13 minutes!!

    I will try and work out what the theme is doing and prevent the extra tab from opening.

    Q2. True, my fault, it's been a long day!

    I will try and change the settings for my Q3.

    Regards
    Keith

  4. Sayontan Sinha
    Member
    Plugin Author

    Posted 1 year ago #

    I figured out a workaround for Q1 with respect to your theme, so if you can stay tuned for the next release this shouldn't be a problem (assuming your theme's author hasn't got back to you).

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.