WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
Photon and UNICODE (10 posts)

  1. ranpha
    Member
    Posted 1 year ago #

    If the URL of an image in my blog posts/pages have Unicode characters in it, the Photon CDN caching will not work with that image. Image that doesn't have Unicode characters in them works just fine.

    Example of a post with images that has Unicode characters in its URL - http://wp.me/prgSo-zU

    Example of a post with images that doesn't have Unicode characters in its URL - http://wp.me/PrgSo-b1

    http://wordpress.org/extend/plugins/jetpack/

  2. Sheri Bigelow (designsimply)
    Member
    Plugin Contributor

    Posted 1 year ago #

    I checked your site with the Jetpack debug tool at http://jetpack.me/support/debug/ and it shows that Photon is not enabled. Please enable Photon and reply back so I can take a closer look.

  3. ranpha
    Member
    Posted 1 year ago #

    I now have enabled it, all the posts that has images with Unicode paths in it failed to render.

    I found out that this will happen only for posts in the front page, but not in individual posts.
    For example, the front page has 3 posts ( http://wp.me/prgSo-zN http://wp.me/prgSo-zt and http://wp.me/prgSo-zU ) with Unicode image paths, and all their images failed to render. If the posts are opened individually, the images will appear (mainly because they are not CDNed).

    I will disable Photon 12 hours from the time I posted this message.

  4. Sheri Bigelow (designsimply)
    Member
    Plugin Contributor

    Posted 1 year ago #

    I checked the first link you provided http://wp.me/prgSo-zN and I don't see any broken images. Can you provide a direct image URL of one of the images that looks broken to you?

  5. Sheri Bigelow (designsimply)
    Member
    Plugin Contributor

    Posted 1 year ago #

    Sorry, I didn't read your last report closely enough where you said the images work fine when the posts are opened individually. I checked the home page and I found an example of a broken image. Here is an example URL:

    http://i2.wp.com/reviews.anime.my/LittleBattlerseXperience(%E3%83%80%E3%83%B3%E3%83%9C%E3%83%BC%E3%83%AB%E6%88%A6%E6%A9%9F)/lbx-themainprotagonist.jpg

    However, the non-photon version of that same image is also broken when I try to check it:

    http://reviews.anime.my/LittleBattlerseXperience(%E3%83%80%E3%83%B3%E3%83%9C%E3%83%BC%E3%83%AB%E6%88%A6%E6%A9%9F)/lbx-themainprotagonist.jpg

    I noticed the broken images all seem to have parentheses characters in them.

    Can you please try disabling photon again so I can look at the http://imouto.my/ page again to see if I can find anything different in the URLs after that?

  6. ranpha
    Member
    Posted 1 year ago #

    I have disabled Photon, and all images in the front page now appears correctly.

  7. Sheri Bigelow (designsimply)
    Member
    Plugin Contributor

    Posted 1 year ago #

    Thanks. I checked the image I found before, and it is still broken:
    http://reviews.anime.my/LittleBattlerseXperience(%E3%83%80%E3%83%B3%E3%83%9C%E3%83%BC%E3%83%AB%E6%88%A6%E6%A9%9F)/lbx-themainprotagonist.jpg

    So that was not a good test.

    However, I noticed some smaller images that I couldn't see before, such as http://naruto.anime.my/wp-content/uploads/2012/11/facepalm_thumb.gif

    I think this update will fix that problem:
    http://plugins.trac.wordpress.org/changeset/622713

    If you are comfortable updating PHP files, you can try to apply the changes from that link on your own. If not, just wait for Jetpack version 2.0.1 to be released and I think that will solve the problem for you.

  8. ranpha
    Member
    Posted 1 year ago #

    With the 2.0.2 update, the problem still exists. I think Photon mangles the images URL so it is shown wrong.

    Oh BTW, the correct image URL you have cited above should be

    http://reviews.anime.my/Little%20Battlers%20eXperience%20(%E3%83%80%E3%83%B3%E3%83%9C%E3%83%BC%E3%83%AB%E6%88%A6%E6%A9%9F)/lbx%20-%20the%20main%20protagonist.jpg

    not

    http://reviews.anime.my/LittleBattlerseXperience(%E3%83%80%E3%83%B3%E3%83%9C%E3%83%BC%E3%83%AB%E6%88%A6%E6%A9%9F)/lbx-themainprotagonist.jpg

    Apparently, Photon removes all spaces from the URL when caching them into the CDN.

  9. Sheri Bigelow (designsimply)
    Member
    Plugin Contributor

    Posted 1 year ago #

    Apparently, Photon removes all spaces from the URL when caching them into the CDN.

    This probably ins't just a Photon thing. You should not use spaces in your file names.

  10. Sheri Bigelow (designsimply)
    Member
    Plugin Contributor

    Posted 1 year ago #

    Checking back in. Here is a Q&A about why you shouldn't use spaces in filenames:
    http://superuser.com/questions/29111/what-technical-reasons-exist-for-not-using-space-characters-in-file-names

    Do you have any examples of specific images without spaces in the filenames that are broken when you turn on Photon?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic