WordPress.org

Ready to get started?Download WordPress

Forums

Portfolio Slideshow
Photo Slideshow navgation buttons wont work (5 posts)

  1. soyale
    Member
    Posted 1 year ago #

    Hello,

    My photo slideshow seems to not be working (the next, prev and play buttons wont work) any suggestions?

    http://eatfeastnyc.com/gallery/

    Thanks,
    Allie

    http://wordpress.org/extend/plugins/portfolio-slideshow/

  2. ultraloveninja
    Member
    Posted 1 year ago #

    Looks like your theme isn't pulling in jquery correctly.

    I looked at it in Google chrome and went to the console tab and it was showing that couldn't find the jquery resource.

  3. soyale
    Member
    Posted 1 year ago #

    I'm really new at wordpress, do you mind telling me how to install jquery, I seem not to have it installed and I'm not sure how to install it. THANK YOU!

  4. ultraloveninja
    Member
    Posted 1 year ago #

    jQuery should already be installed, or the URL to the jQuery library should be in your theme already.

    There should be a setting within your functions.php file within your theme that points to a jQuery URL.

    From inspecting your site with Chrome it appears that there are some URL's to some JavaScript libaraies that appear to be broken/missing:

    http://eatfeastnyc.com/wp-content/themes/cloriato-lite/js/slides.min.jquery.js?ver=3.5.1

    http://eatfeastnyc.com/scripts/updatepage.js

    Unfortunately, since I am not familiar with your current setup or your site, I cannot really say if this it the cause for the slider not working correctly. It could be that these URL to these javascript libraries are missing, but it could be conflict with another plugin as well.

    My suggestion would be to first, clear these error with the missing libraries and see if that resolves the issue. If the thumbnails are still not working, then I would then check with the Google Chrome inspector under the console tab and see if there are any other errors that are being triggered. If so, then you might have a conflict with a couple plugins.

    That's the best advice I can give you right now.

  5. soyale
    Member
    Posted 1 year ago #

    This is what appears on my functions.php

    <?php
    
    include_once get_template_directory() . '/functions/inkthemes-functions.php';
    $functions_path = get_stylesheet_directory() . '/functions/';
    /* These files build out the options interface.  Likely won't need to edit these. */
    require_once ($functions_path . 'admin-functions.php');  // Custom functions and plugins
    require_once ($functions_path . 'admin-interface.php');  // Admin Interfaces (options,framework, seo)
    /* These files build out the theme specific options and associated functions. */
    require_once ($functions_path . 'theme-options.php');   // Options panel settings and custom settings
    
    function inkthemes_jquery_init() {
        if (!is_admin()) {
            wp_enqueue_script('jquery');
            wp_enqueue_script('ddsmoothmenu', get_stylesheet_directory_uri() . "/js/ddsmoothmenu.js", array('jquery'));
            wp_enqueue_script('confu', get_stylesheet_directory_uri() . '/js/cufon-yui.js', array('jquery'));
            wp_enqueue_script('font', get_stylesheet_directory_uri() . '/js/Champagne.font.js', array('jquery'));
            wp_enqueue_script('validate', get_stylesheet_directory_uri() . '/js/jquery.validate.min.js', array('jquery'));
            wp_enqueue_script('verif', get_stylesheet_directory_uri() . '/js/verif.js', array('jquery'));
            wp_enqueue_script('tabbedcontent', get_stylesheet_directory_uri() . '/js/slides.min.jquery.js', array('jquery'));
            wp_enqueue_script('custom', get_stylesheet_directory_uri() . "/js/custom.js", array('jquery'));
        } elseif (is_admin()) {
    
        }
    }
    
    add_action('init', 'inkthemes_jquery_init');
    
    function inkthemes_get_option( $name ) {
    	$options = get_option( 'inkthemes_options' );
    	if ( isset( $options[ $name ] ) )
    		return $options[ $name ];
    }
    function inkthemes_update_option( $name, $value ) {
    	$options = get_option( 'inkthemes_options' );
    	$options[ $name ] = $value;
    
    	return update_option( 'inkthemes_options', $options );
    }
    function inkthemes_delete_option( $name ) {
    	$options = get_option( 'inkthemes_options' );
    	unset( $options[ $name ] );
    
    	return update_option( 'inkthemes_options', $options );
    }
    ?>

    Now regarding the javascript, where can I look into that to clear the error? maybe I did erase something...

    btw, THANK YOU! You have helped me soo much!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.