WordPress.org

Ready to get started?Download WordPress

Forums

Photoswipe for NextGEN Gallery
[resolved] photo grayed out on mobile (3 posts)

  1. cmontague7
    Member
    Posted 1 year ago #

    Hi. I have photoswipe installed on http://www.danielletibedo.com
    I'm also using NextGen Optimizer. When I click on the gallery on a mobile device, the photo pops up and is grayed out. I have to click on it once to make it show correctly, then I can begin swiping. What is wrong? How can it be fixed so that when a user clicks on the first image on the page, it pops up correctly?

    thanks

    http://wordpress.org/extend/plugins/photoswipe-for-nextgen-gallery/

  2. Guillermo Seņas
    Member
    Plugin Author

    Posted 1 year ago #

    You are using a non-standard version of fancybox.

    Edit the file ngg-photoswipe-disable-fancybox.js, and replace line 3 for this content:

    jQuery('a.myfancybox').unbind('click.fb').addClass('nolightbox').removeClass('myfancybox');

    Tick the checkbox to disable Fancybox in the plugin options.

  3. cmontague7
    Member
    Posted 1 year ago #

    I just made that change, but when I click "disable fancybox" and then refresh the page, the "disable fancybox" box is unchecked. It doesn't stay checked, and the problem with the graying out on the ipad is still occurring.

    Here is the full code I now have in the file ngg-photoswipe-disable-fancybox.js

    jQuery(document).ready(function(){
    //Remove fancybox effect:
    jQuery('a.myfancybox').unbind('click.fb').addClass('nolightbox').removeClass('myfancybox');
    });

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags