WordPress.org

Ready to get started?Download WordPress

Forums

OTW Portfolio Light
[resolved] Personalize the name /otw-portfolio/ in permanent link (8 posts)

  1. allenb
    Member
    Posted 10 months ago #

    Because what I am displaying are not exactly porfolios but some services, I would like to change and personalize the name on the permanent link http://domainname/otw-portfolio/pagename

    I'll changed the filterable permanent link, in php files, but I'm not sure how to change on the pages permanent link. What camps in which files do I have to change it?

    I would appreciate some help.

    Thank you.

    http://wordpress.org/plugins/otw-portfolio-light/

  2. OTWthemes
    Member
    Plugin Author

    Posted 10 months ago #

    Hi,

    We do not have such option in the plugin. By default the plugin will use the custom post type name.

    You can try this plugin http://wordpress.org/plugins/custom-post-type-permalinks/ although it has not been tested.

    OTWthemes

  3. brian11
    Member
    Posted 10 months ago #

    This is something I'd like to do as well. The custom post type permalinks plugin does not work to change the "otw-portfolio" in the URL. The plugin only allows you to change the slug AFTER otw-portfolio. So your URL still looks like mysite.com/otw-portfolio/CUSTOMIZABLE-SLUG. Which is redundant because you can already change that slug in the portfolio options.

    The theme demo of your theme Carbon that uses the portfolio plugin does not have the "otw-portfolio" in the URL. As seen in this URL:

    otwthemes.com/demos/carbon-wp-light/portfolio-paginated/

    Then again when clicking on an actual portfolio item:
    otwthemes.com/demos/carbon-wp-light/portfolio/development-portfolio-item-3/

    I've tried changing some stuff in the php files to change the custom post name but it doesn't work properly.

    I would really like to use this plugin but unless I can change the otw-portfolio in the URL I won't be using it. Could you not provide the customized files similar or the same as the ones in your demo? Or explain which files need to be edited...there are a lot of otw-portfolio instances in the few php files with the plugin.

    Thanks.

  4. allenb
    Member
    Posted 10 months ago #

    I agree with you Brian.
    Can you provide how to customize this otw-portfolio in php files. The plugin doesn't work.
    Thank you!

  5. winsion
    Member
    Posted 9 months ago #

    To Brian11,
    Same to me , won't use unless delete "otw-portfolio"....

  6. bob2013
    Member
    Posted 9 months ago #

    just open the file wp_content/plugins/otw-portfolio/otw-portfolio-light.php, find the line 56 and change it from

    'rewrite' => true,

    to

    'rewrite' => array('slug' => 'portfolio','with_front' => false),

    save the file, goes to settings > permalinks and click save button to flush url rewrite rules. Now goes to the single project page again, the url now is “http://www.lowerthanwater.com/portfolio/bouf/”, perfectly solved!

  7. photoMaldives
    Member
    Posted 8 months ago #

    nice one, bob - if your hack works, then this plugin might just be what I'm after ...

  8. quantaweb
    Member
    Posted 8 months ago #

    The solution above works beautifully. Be sure to save your permalink settings afterward, the URL will show as you wish it to.

Reply

You must log in to post.

About this Plugin

About this Topic