WordPress.org

Ready to get started?Download WordPress

Forums

Permissions/image uploads (7 posts)

  1. Shegee
    Member
    Posted 5 years ago #

    I'm new to WordPress and want to upload images. I'm getting the message:
    Unable to create directory /var/www/vhosts/example.com/httpdocs/wordpress/wp-content/uploads/2009/04. Is its parent directory writable by the server?

    I've read about permissions, changed some files & folders, royally screwed it up so much that I had to delete all wordpress files from the server & re-upload them. I can now get back into my site again so am anxious not to change too much again.

    Any ideas how I easily allow access so I can upload images?

    Thanks,

    Sheri

  2. esmi
    Forum Moderator
    Posted 5 years ago #

    Have you read/worked though:

    http://codex.wordpress.org/Changing_File_Permissions

    It doesn't get much easier than that.

  3. Shegee
    Member
    Posted 5 years ago #

    Yes, that got me into a lot of trouble. I changed file permissions for the index.php and it didn't get me anywhere. It currently has 664 (user rw, group r, user r).

    Does that sound right, or too little access?

    Thanks,
    Sheri

  4. ClaytonJames
    Member
    Posted 5 years ago #

    Unable to create directory /var/www/vhosts/example.com/httpdocs/wordpress/wp-content/uploads/2009/04. Is its parent directory writable by the server?

    You can try changing the permissions on just the wp-content folder TEMPORARILY to 777. Go back and upload the image, and see if WordPress creates the "uploads" folder this time (no error messages). Then go back and change the permissions on the wp-content directory back to 755. Don't leave the folder at 777.

  5. Shegee
    Member
    Posted 5 years ago #

    Thanks to all who helped. I've managed to put it right with this link: http://wordpress.org/support/topic/164003?replies=6

    (basically changing settings - miscellaneous - uncheck 'Organize my uploads into month- and year-based folders' box.

    Save. All solved. Who'd have thought it.

    No permissions changes needed. Some lovely person on Twitter sent me the link.

    Thanks all.
    Sheri

  6. benz001
    Member
    Posted 5 years ago #

    Also check Settings > Miscellaneous to see what your upload path is, this won't be a url, instead it will be a local directory path on the hosting server - something like "/home/username/mainwebsite_html/wp-content/uploads", try the default that wordpress suggests first on that screen.

    If that doesn't work you'll have to login to your hosting control panel/use your ftp program to figure out the actual path.

    I just moved a blog from one host to another and - woops - forgot to change this setting for the new host, got exactly this error.

  7. slobizman
    Member
    Posted 4 years ago #

    I also have a problem where I have to have my uploads folder set at 777 to be able to upload an image from within a post. I've read everything I could find about this in the forums, and it seems lots of people are having problems.

    I just tried what ClaytonJames above said:

    You can try changing the permissions on just the wp-content folder TEMPORARILY to 777. Go back and upload the image, and see if WordPress creates the "uploads" folder this time (no error messages). Then go back and change the permissions on the wp-content directory back to 755. Don't leave the folder at 777.

    But when I do this the owner of the created uploads folder is "99", not me as the owner like if I created the folder myself in FTP or cpanel. As a result, it is not letting me change the File Permissions to 755 or anything else afterwards. So. I'm stuck at 777, which scare me.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.