WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permissions Issues With Updating and Widgets Menu (24 posts)

  1. goldferris
    Member
    Posted 2 years ago #

    Hi!

    I've had my self-hosted WordPress blog (MakeupFiles.com) for over 3 years now. All of a sudden (I assume it happened after an update), WordPress doesn't seem to think I have authority to make big changes.

    - Now, instead of giving me an "update automatically" link at the top of the admin for the new 3.2 update, it says "Please notify the site administrator."

    - My Widgets menu has disappeared from the sidebar. I assume it's also a permissions issue. I followed steps from other threads saying to change edit_theme to switch_theme in the functions file, but that didn't get my Widgets menu back.

    For reference, I only have one user for my blog--Me-and it's the default "admin" login username. None of that has changed.

  2. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    Do you use WP-Insert?

    http://wordpress.org/extend/plugins/wp-insert/

    Causes all the side bars in the admin dashboard to vanish. New version released on July 5th resolves this.

  3. goldferris
    Member
    Posted 2 years ago #

    Nope, I don't have WP-Insert. And I'm not missing the sidebars. Just the "Widgets" menu from the Appearances section. Everything else is there.

  4. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    Have you tried:

    - deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). Don't forget the ones in mu-plugins. If you can't get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - switching to the Twenty Ten theme to rule out any theme-specific problems.

  5. goldferris
    Member
    Posted 2 years ago #

    Thanks, Kmessinger.

    - I deactivated all plugins, signed out, and signed back in. It didn't fix the problem.

    - I switched to Twenty Ten, signed out, and signed back in. It didn't fix the problem (including the lack of "Widgets" in the Appearance menu.)

  6. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    Go to dashboard users. Create a new user (you) - you will need a different email address - give that user admin rights. Log off and log on as the new user.

  7. goldferris
    Member
    Posted 2 years ago #

    I really don't want to create a new user if I don't have to (I prefer getting my WordPress emails at the email address I chose originally). Is there a way to change the current user (admin) to administrator? Perhaps in PHPmyAdmin panel in the database?

  8. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    So? Delete the old admin user and then change the email address back to your preferred one.

  9. goldferris
    Member
    Posted 2 years ago #

    Okay, I added a new user, assigned it as an "Administrator." Then I logged in as that user and it has the same problems as the original. It still says I need to contact the site admin to update wordpress, and there still isn't a Widgets section in the Appearance menu.

    So, My problem still isn't fixed.

  10. goldferris
    Member
    Posted 2 years ago #

    I'm still not sure what to do about this. I feel like my problem must be in the database somewhere, but I don't know where to look. wp_users? wp_options?

    I searched around the internet and didn't find anything.

    I thought about maybe updating WordPress manually, but I'm afraid that since I don't have permissions anymore, it won't let me complete the update once I upload it through FTP and sign in again. I'd hate to disable my site completely that way.

    And I still can't edit my widgets anymore because of this, and that's a problem.

    Anyone have any new advice. I haven't gotten a reply in over a week.

  11. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    Using PhpMyadmin (or another MySQL managament tool), first backup your database. Then navigate to your wp_usermeta table and locate the meta_key called "wp_capabilities" for your user_id. Change the meta-value for this record to:

    a:1:{s:13:"administrator";b:1;}

  12. goldferris
    Member
    Posted 2 years ago #

    Thanks, Esmi...

    I found "wp_capabilities" in the database and the meta-value is already what you said it should be.

    I really don't know what to do about this...

  13. Digital Raindrops
    Member
    Posted 2 years ago #

    Hi,
    Just floating an idea might be well off base, is this a multi-site install?

    I know that in multi-site you get this message and there are settings in wp-config that point to the primary blog id, might be worth a look?

    Do you have a membership plugin that has a capabilities matrix for different user types?

    Could be a plugin that is causing this?

    David

  14. goldferris
    Member
    Posted 2 years ago #

    Nope, this isn't a multi-site install and I don't have a membership plugin.

    It's weird, because my usermeta data in the database has the administrator string "a:1:{s:13:"administrator";b:1;}".

    But it still doesn't think I'm an administrator. I really am at a loss.

    I tried this thread, but it didn't apply since mine already says administrator in the database: http://wordpress.org/support/topic/logged-in-as-admin-or-am-i

    And while this thread looked promising to me, like it might help my issue, I don't understand it enough to apply it to my own situation: http://wordpress.org/support/topic/you-do-not-have-sufficient-permissions-to-update-plugins-for-this-blog?replies=9

    Sigh....

    Please, PLEASE someone help me. I'll give you a virtual hug in return. You know you want one.

  15. goldferris
    Member
    Posted 2 years ago #

    I know I'm not supposed to bump, bu i last mentioned this a month ago and I still haven't gotten a reply. Is there anyone out there that can help me?

  16. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    Have you tried a diffent browser?

  17. goldferris
    Member
    Posted 2 years ago #

    I don't know how that would matter (especially since I have two other blogs without this problem), but I tried it anyway.

    It still had the same problem in Internet Explorer as it does in Firefox.

    Thanks, though!

  18. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    Browsers look at code in slightly different ways.

    Where you checked the user capabilities, under that is user levels. It should be a 10 afaik so check that.

  19. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    Since you can login and for the most part function why not do a manual upgrade. That should fix and problems that have developed in the backend since you last upgraded.

  20. goldferris
    Member
    Posted 2 years ago #

    I looked for user levels under usermeta and couldn't find it, so I looked it up and found that they phased out user levels at WP 2.0.

    I decided to manually upgrade. I'd been avoiding that because I thought it might make my problem worse.

    While it did update wordpress, it didn't fix the permissions. I still can't access widgets, for example. Even though I'm an admin, it's not letting me act like one.

    My problem isn't solved.

  21. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    they phased out user levels at WP 2.0.

    Guess that tells you how old my database is.

    I use this plugin, http://wordpress.org/extend/plugins/user-role-editor/ to change roles. You could try this to see if it will change your role.

  22. thesm2
    Member
    Posted 2 years ago #

    i think I had a very similar problem for months. Struggled along without being able to create users of update WP, but could post and some other admin tasks.

    I found this thread a way to my solution

    http://wordpress.org/support/topic/moving-wordpress-admin-issue-help-please

    just go to the wp-options table...find the option name 'wp_user_roles' and paste in the new code used by user ODGraphics.

    see if that works?

  23. goldferris
    Member
    Posted 2 years ago #

    YAY!!!! Thank you so much, thesm2! That fixed it! Finally!

    I'm going to mark this one as Resolved. :)

  24. eyal777
    Member
    Posted 2 years ago #

    cool :) thanks goldferris and thesm2

Topic Closed

This topic has been closed to new replies.

About this Topic