WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permissions and compat.php (3 posts)

  1. heriz
    Member
    Posted 6 years ago #

    Oh dear. I just tried to 'harden' my WP blog using the security tutorial on this site, and something has gone horribly wrong. I found myself suddenly unable to do anything at all, despite only having changed the said CHMOD permissions to 744. I now receive this error page:

    Warning: main(/.../.../.../.../wp-includes/compat.php) [function.main]: failed to open stream: Permission denied in /home/.../public_html/.../wp-settings.php on line 117

    Warning: main(/.../.../.../.../wp-includes/compat.php) [function.main]: failed to open stream: Permission denied in /home/.../public_html/.../wp-settings.php on line 117

    Fatal error: main() [function.require]: Failed opening required '/.../.../.../.../wp-includes/compat.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/.../public_html/.../wp-settings.php on line 117

    Line 117 in wp-settings.php being

    require (ABSPATH . WPINC . '/compat.php');

    I've now been forced to put a 777 CHMOD on everything to see if it reverses the error. It hasn't. I'm now unable to move within my admin, and get that error every time I try to do anything.

    Clearly I've made a big mistake but does anyone know how to remedy it?

    Huge thanks in advance...

    Lewis

  2. heriz
    Member
    Posted 6 years ago #

    ... and the blog no longer works at all.

    It's still under construction so it's not being viewed by anyone yet.

  3. heriz
    Member
    Posted 6 years ago #

    Right, sorted... some files/folders in the wp-includes directory were set at 744.

    I'll just have to be a bit more careful in the future...

Topic Closed

This topic has been closed to new replies.

About this Topic