WordPress.org

Ready to get started?Download WordPress

Forums

Permissions and chmod (20 posts)

  1. Jaxia
    Member
    Posted 9 years ago #

    When trying to install different plugins, I keep getting permission errors. I put this under how-to because I think I might have one big problem - I don't understand! :)

    I figured out one problem - my install did not create a .htaccess file. I did manage to create that and get permalinks to work. I've been trying to get threaded comments and the acronym plugin to work (among others).

    When I FTP, and right click for permissions, I don't see the box that will let me type a number. I just have the check boxes. So, I guess I'm looking for two things:
    1. Which boxes should I check?
    2. Which files should I change permissions for?

    I realize these are totally n00b questions, but I appreciate the help!
    Thanks!
    ~Jaxia

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Check boxes are okay.
    Exactly what is the error you get ?

    http://www.tamba2.org.uk/wordpress/ftp/

  3. Jaxia
    Member
    Posted 9 years ago #

    For the Acronym plugin, I get:

    Warning: fopen(...stealtheblinds.net/wp-content/plugins/../acronym-revisited-config.php): failed to open stream: Permission denied in ...stealtheblinds.net/wp-content/plugins/acronym-revisited.php on line 85
    Error Opening File

    When I click the link to manage my acronyms, I get the same error.

    Ideas?
    Thank you so much!
    ~Jaxia

  4. Jaxia
    Member
    Posted 9 years ago #

    I also get:

    Threaded Comments Error
    There is a column missing from the database that the threaded comments needs to work.
    This can be caused by forgetting to activate the plugin.
    If the plugin is activated, chances are that you don't have permission to change the table.
    If this is the case, and you do not already know how to fix it based on this information, you need to contact your server administrator and ask him/her to grant your database user permission to alter tables.

    Any ideas?

  5. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Working from the inside out:
    make 'plugins' 755
    see if that works, if not try 766 if not try 777
    If still no joy
    make 'wp-content' 755
    see if that works, if not try 766 if not try 777

    You could just set them to 777 first and see if they work, then try and reduce them to 755. Bit of trial and error here - it's just the way hosts set up their servers so there is no definitive answer.

  6. Mark (podz)
    Support Maven
    Posted 9 years ago #

    With the threaded comments error, you need to run the install file. Did you ?

  7. Jaxia
    Member
    Posted 9 years ago #

    I know I'm lame, but I am just using the built in FTP from windows. Is there a way to CHMOD from it?

    If not, I have cuteftp on another computer and will check it out later.

    As for the threaded install...the zip file I downloaded has 3 files in it: comments.php, briansthreadedcomments.php and install.txt

    The txt file just tells me where to put the files, which I followed. Is there something else?

    Thanks for the prompt response!

  8. Mark (podz)
    Support Maven
    Posted 9 years ago #

    The inbuilt ftp thing in windows is worse than useless :)
    Cuteftp is okay.

    I'm mistaken about the install for the comments ....

  9. Jaxia
    Member
    Posted 9 years ago #

    I know it sucks, but I'm at work so I take what I can get. I have cuteftp on my home PC and will check out the chmod stuff there.

    Yeah, no idea what's wrong with the comments thing. I think I'm just having general permission problems. (I hope that's all, anyway)

    Thanks again and I hope it works :D

  10. Jaxia
    Member
    Posted 9 years ago #

    Well, I tried every possible combination, and still no joy.

    When I click on 'manage your acronyms' from the wordpress admin panel, it tries to take me to this address:

    http://www.stealtheblinds.net/wp-content/plugins/acronym-revisited.php?option=admin

    and gives this error:

    Warning: fopen(/stealtheblinds.net/wp-content/plugins/../acronym-revisited-config.php): failed to open stream: Permission denied in /stealtheblinds.net/wp-content/plugins/acronym-revisited.php on line 85
    Error Opening File

    If the plugin is active, my home page gives the same error.

    Help?

  11. Mark (podz)
    Support Maven
    Posted 9 years ago #

    There is a possibility that your host does not allow the 'fopen' function. you could email them and ask ?

  12. NinaW
    Member
    Posted 8 years ago #

    I am getting exactly the same error with the same plugin. I think there is something wrong with that plugin.

    Another guy who has that problem:
    http://wordpress.org/support/topic/12962

  13. NinaW
    Member
    Posted 8 years ago #

    Doh! Just realized you wrote the other thread too ;-)

  14. NinaW
    Member
    Posted 8 years ago #

    Hm, just something that came to my mind ... the plugin is looking for a file called "acronym-revisited-config.php", but that file is not in the ZIP?

  15. NinaW
    Member
    Posted 8 years ago #

    I am now using this plugin:
    http://www.coffee2code.com/archives/2004/06/29/plugin-text-replace/

    It works perfectly. I used it likes this:
    [code] "[dpi]" => "dpi",[/code]

    That way I have to write [dpi] if I want the word to be defined as acronym, but I don't have to fear that I get the <a href-problem that all these acronym-plugins have.

  16. NinaW
    Member
    Posted 8 years ago #

    Dang, without the [code] and [/code] of course ...

  17. NinaW
    Member
    Posted 8 years ago #

    Sorry, my example didn't work because I don't know how to write code here. So it deleted my HTML :-/

    I am trying it again ...:
    (code)"[dpi]" => "dpi",(/code)

  18. NinaW
    Member
    Posted 8 years ago #

    Doh ^^

  19. NinaW
    Member
    Posted 8 years ago #

    Ah nevermind, just check out the plugin I mentioned.

  20. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Look for the key on your computer with ¬ on it ?
    It's also got the backtick
    Put your code inside of two

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.