WordPress.org

Ready to get started?Download WordPress

Forums

SI CAPTCHA Anti-Spam
permissions (7 posts)

  1. wadams92101
    Member
    Posted 3 years ago #

    For some reason, the captcha-temp file seems to periodically revert to unwriteable blocking all new registrations.

  2. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    Please explain in more detail the permission it reverts to and what you change it to to make it work again.
    http://codex.wordpress.org/Changing_File_Permissions

    And is there a related event to when this occurs, like just after updating the plugin?

  3. wadams92101
    Member
    Posted 3 years ago #

    Thank you for your quick response. It reverts from 777 to 755. At 755, it doesn't allow user registrations. Not sure about the update. I have many plugins. When was the last update for this one?

  4. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    It probably happens during the plugin upgrade, the last upgrade was June 2, but you could have installed it anytime after that.
    Please test something for me so I would know if making a code change would help or not:

    1. look at the permissions of the folder captcha-temp
    2. delete the folder captcha-temp
    3. open a page on your site with the captcha, like a comments page that shows it.
    4. Did the folder regenerate on its own? (it should)
    What is the permissions now?

    Then edit the si-captcha.php file
    find this code in the function si_captcha_init_temp_dir:

    wp_mkdir_p( $dir );
    @chmod( $dir, 0733 );

    change it to:

    wp_mkdir_p( $dir );
    //@chmod( $dir, 0733 );

    repeat steps 1-4, then let me know the answers of #4 after the change

    If this fixes it, i can make the change part of the next version i release.

  5. wadams92101
    Member
    Posted 3 years ago #

    No, it did not regenerate. I even entered the captcha code just in case I had to a little further and it generated the message below. Should I still make the code change? OR should I uncheck the box as mentioned in the error message?

    ERROR: Could not read CAPTCHA token file.
    There is a problem with the directory /si-captcha-for-wordpress/captcha-secureimage/captcha-temp/.
    The directory is not found, a permissions problem may have prevented this directory from being created. Fixing the actual problem is recommended, but you can uncheck this setting on the si captcha options page: "Use CAPTCHA without PHP session" and the captcha will work this way just fine (as long as PHP sessions are working).

  6. Mike Challis
    Member
    Plugin Author

    Posted 3 years ago #

    Try unchecking the setting "Use CAPTCHA without PHP session"
    Make sure it works. It will not need the captcha-temp folder.
    That might be best for your server setup.

  7. wadams92101
    Member
    Posted 3 years ago #

    That's what I did and it works. I'm going to call it a day. Thank you for quick help. I also changed my to "it works."

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic