WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permissions (15 posts)

  1. simmer
    Member
    Posted 8 years ago #

    First Merry xmas all!
    Second my problem :(

    The installation was no problem but i'am having big trouble with the premissions... I used the following table http://www.tamba2.org.uk/wordpress/chmod/ and wordpress is still NOT letting me upload any files. I also made a dir(media) and chmod 777 on this and it's still giving me the finger for uploading..

    I'am using Servage hosting(could this be the problem?) and found some wordpress pages that work.. COuld anybody help me solving this problem? I tried many things as posted in the forum but no luck :(

    thanks already!

  2. VxJasonxV
    Member
    Posted 8 years ago #

    What's the error message you're getting?

  3. schestowitz
    Member
    Posted 8 years ago #

    Have you insured that the entire path of directories enables you to access and write to /uploads? As far as I know, you must go up the levels (diretcory hierarchy), insuring that even your WordPress directory is writable (not /admin!). Hope it helps and merry Xmas!

  4. moshu
    Member
    Posted 8 years ago #

    As far as I know, you must go up the levels (diretcory hierarchy), insuring that even your WordPress directory is writable

    I never had to do that. Making writable just the wp-content for example, was always enough to use the upload feature.

  5. simmer
    Member
    Posted 8 years ago #

    Thanks for the replying!. I get the following error;"It doesn't look like you can use the file upload feature at this time because the directory you have specified (home/goochie/public_html/wp-content) doesn't appear to be writable by WordPress. Check the permissions on the directory and for typos."

    With wordpress 2.0 i get this error with uploading;Warning: mkdir(): SAFE MODE Restriction in effect. The script whose uid/gid is 6299/6299 is not allowed to access /mounted-storage/home8/sub003/sc15333-USOR/www/wp-content/uploads/2005 owned by uid/gid 99/99 in /mounted-storage/home8/sub003/sc15333-USOR/www/wp-includes/functions-post.php on line 843
    Unable to create directory /mounted-storage/home8/sub003/sc15333-USOR/www/wp-content/uploads/2005/12. Is /mounted-storage/home8/sub003/sc15333-USOR/www/wp-content/uploads/2005 writable?
    I found serveral solutions on this site but nothing works for me.

  6. moshu
    Member
    Posted 8 years ago #

    SAFE MODE Restriction in effect
    I am afraid that's the key - that's how your host set up the server.

  7. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Previously, Safe Mode had no effect on WP.
    However, 2.0 creates image directories every month (it's a feature) - and if Safe Mode means that the mkdir command does not work then you will have to use your file manager of ftp to create those directories for WP.

    Far far from ideal.

  8. simmer
    Member
    Posted 8 years ago #

    So there is no solution? Like a sais earlier there some sites running on servage hosting.. So it must be possible..but how ;)

  9. schestowitz
    Member
    Posted 8 years ago #

    You could run a script to create the all the directories you will ever need instead. I won't manage to find the pseudo-code I wrote before, but you could create directories for years, put all month within each of these and then dates. A simple script can do all of this. If you don't run the script on the server, you could run it locally and then upload all the directories via FTP.

    @Podz - would it be useful if I created a sort of directory structure 'template' and zipped it? People with such limitation can uncompress it and upload... I think this would be handy.

  10. simmer
    Member
    Posted 8 years ago #

    i went back to v1.5.2 and managed to upload files but only when i changed the upload-dir to chmod777. I'am a graphic designer and not really into rights.. Can er be harm done when i set this to 777?

    I turned off safe mode on my host, is there a way to secure wp when this is turned off?

  11. Mark (podz)
    Support Maven
    Posted 8 years ago #

    777 for any directory must be avoided - if that is the only permission that your host will allow for uploads, start lookin for another host.

  12. simmer
    Member
    Posted 8 years ago #

    looks like it :(..
    I will sent hem another mail if they know another way to solve this..

    Thanks for all your help

  13. schestowitz
    Member
    Posted 8 years ago #

    As an initiative to follow my suggestion: if you choose to stick with safe mode and cannot build directories, consider this 7KB ZIP archive: http://www.schestowitz.com/temp/upload_dirs.zip

    upload the directories within to <wp_installation_dir>/wp-content/

    When decompressing and uploading, directories might preserve permission 777, but I think some platforms/programs alter permissions (downwards) in the process. I should stress that you should *MERGE*, not overwrite when uploading, or else you might lose existing files

    Note: I was previously mistaken to think that there was a directory level for days of the month

  14. simmer
    Member
    Posted 8 years ago #

    @schestowitz

    Is this for wordpress 1.5.2?

  15. simmer
    Member
    Posted 8 years ago #

    Hiya i think i found the solution for the problem.. My changed the owner permission of the upload-directory in the isp-control panel from 'you'to 'webserver' and i can upload files and create directories with it!!
    Maybe it's gonna be an happy xmas for me after all!

    Thanks for al your help and effort!

Topic Closed

This topic has been closed to new replies.

About this Topic