WordPress.org

Ready to get started?Download WordPress

Forums

Permission Settings (6 posts)

  1. agentsolutions
    Member
    Posted 5 years ago #

    Hi all!

    I came across something very weird today. I have logged into three of my WP dashboards and wanted to edit the theme via the Theme Editor and there was a message at the bottom that reads:

    You need to make this file writable before you can save your changes. See the Codex for more information.

    I have edited the theme via the Theme Editor before without any problems and now I can't. I followed the Codex instructions and it still didn't work.

    Do any of you know why this has happened all of a sudden and how I might fix it so I can proceed with editing the theme?

    Any help in this regard would be greatly appreciated.

    Thanks!

  2. sarmadhassan
    Member
    Posted 5 years ago #

    there could be several issues that point to the same problem..

    your host might have done some up gradation and directory/file permissions might be messed up... so check the theme folder/files permissions.. folders normally get 755 while the files have 666.. contact your host support for that..

    if nothing goes well.. you can use an ftp client to upload the theme folder again..

  3. agentsolutions
    Member
    Posted 5 years ago #

    Thank you sarmadhassan. I have a sent an email to my host and hope to hear back from them tomorrow.

    In the mean time I am checking the files and folders and this is what they say:

    The following are set to 755
    cgi-bin
    wp-admin
    wp-content
    wp-includes

    I changed the index.php to 755

    All the rest of the files are at 644.

    Once I make the changes, will that automatically change everything required to edit the theme within the Theme Editor?

  4. sarmadhassan
    Member
    Posted 5 years ago #

    nah.. leave index.php to 644.. i dont think theres nothing wrong on your part until and unless you did any hard coding..

    see what you get from your host then update here !

  5. normanb
    Member
    Posted 5 years ago #

    Agentsolutions,

    The same thing happened to me today. Formerly I could edit the theme - neonglow - and today I saw the same message as you.

    I have read the codex instructions but can't understand them. Can you tell me where the numerical settings you refer to are located? And what do they mean ?

    On the offchance it is a host related issue - my host is fast2host.

    Best wishes

    Norman

  6. agentsolutions
    Member
    Posted 5 years ago #

    Hey normanb,

    I talked to my host today and they were a bit baffled as to why this happened. I was a bit confused by the codex instructions myself. The numerical values I discovered when I went into my sites file manager via the control panel (mine host uses cPanel).

    While in the file manager, I found the folders and files for my site and in the right hand column it tells you the current permission settings. There is a selection to "Change Permission" settings and this is where I went to make the appropriate changes. I am not entirely clear on what the permission settings "should" be. I'm stilling trying to figure that out.

    I'm also trying to determine why this happened in the first place.

    I will post any additional information I find in the next few days.

Topic Closed

This topic has been closed to new replies.

About this Topic