WordPress.org

Ready to get started?Download WordPress

Forums

Permission errors when posting blogspot.com URLs (2 posts)

  1. AmorEntintado
    Member
    Posted 7 years ago #

    Greetings, everyone!

    I searched the support forums for this specific problem and could not find anything similar. If I missed a solution that was already posted, please point me to it and forgive my incompentence :)

    Basically, here is what is happening: A couple of weeks ago, I was contacted by a couple of long-time readers of my blog (www.amorentintado.com) letting me know that when they tried to post a comment, they were met with an Apache error that contained the following statement: "Forbidden - You don't have permission to access /wp-comments-post.php on this server".

    I could not seem to replicate the error by myself, and some other readers were able to comment perfectly well, so I decided to upgrade my WordPress version to 2.0.5 (I was running 2.0.1 - I know, I know) to see if that would get rid of the problem. My originally "unable-to-comment" readers let me know that it didn't, but one offered some further information: When he left out his blog URL from the corresponding commenting field, his comment went through perfectly.

    This led me to some further investigation, and now I have pinpointed the problem: Whenever a URL that contains the "blogspot.com" domain is posted (not only in the URL field of the comments form, but also in any of the other fields and even when I try to publish a new post that contains "blogspot.com" within the text), this Apache permission error pops up.

    Since this problem appeared out of nowhere, I am fairly certain that it has something to do with some filtering software that my hosting company has implemented, or something to that effect, so I'm getting in touch with them as well. But I still wanted to reach out to the WordPress support community to see if somebody out there was ever faced with this same problem, and if so, find out how they managed to solve it.

    Apologies for the lengthy post, and thanks in advance for any helpful hint you might have for me.

    Cheers!

  2. Chris_K
    Member
    Posted 7 years ago #

    Alas, it sure sounds like your host has some serious mod_security stuff going on.

    As I recall, there may be some things you can add to your .htaccess to disable it for a given directory (if the host configs allows it, of course). Perhaps google 'em up and try that?

Topic Closed

This topic has been closed to new replies.

About this Topic