WordPress.org

Ready to get started?Download WordPress

Forums

WP Auto Affiliate Links
[resolved] Permission errors (20 posts)

  1. Dirty Bill
    Member
    Posted 9 months ago #

    I am the admin for the site. I just imported a list into the new site - "You do not have permissions..." error. I go back to the setup - uploads are there. I go to edit an entry - same error, can't edit. This is new behavior. First time I've attempted with the newest version.

    http://wordpress.org/plugins/wp-auto-affiliate-links/

  2. thedark
    Member
    Plugin Author

    Posted 9 months ago #

    Are you able to see the plugin menu and options, but you cannot do actions ?

  3. Dirty Bill
    Member
    Posted 9 months ago #

    Yes, menu shows up, can set options, but when I go to test or sync it starts to process then gives me a blank screen. Can reopen the settings and any changes are there, but won't run. I've tried monitoring it in the browser (Chrome dev tools) - starts to show then blank. Nothing shows in my server logs. Definitely puzzled.

  4. thedark
    Member
    Plugin Author

    Posted 9 months ago #

    Thank you for all your information. I was able to identify the problem and made a new update. Please let me know if it works for you right now.

  5. Dirty Bill
    Member
    Posted 9 months ago #

    Ok, just gave it a try. No more error, but the fields don't update. Tried comma separated values, tried replacing existing text with a single work, nothing. Because of the problems with hyphenated (Ifo Ekpre-Olomu) or punctuated (De'Anthony Thomas) names, being able to link/replace these is important.

    I appreciate your help and this very cool plugin.

  6. thedark
    Member
    Plugin Author

    Posted 9 months ago #

    Hello. I found and fixed a bug in the edit links forms. Is import/export working well for you ?

    I will look tomorrow into hyphenated situation too.

  7. Dirty Bill
    Member
    Posted 9 months ago #

    Import worked fine. Had a long list to bring in. I haven't done an export yet.

  8. Dirty Bill
    Member
    Posted 9 months ago #

    Brand new error with latest update:

    PHP Fatal error: Maximum execution time of 30 seconds exceeded in /website.com/wp-content/plugins/wp-auto-affiliate-links/WP-auto-affiliate-links.php on line 812

  9. thedark
    Member
    Plugin Author

    Posted 9 months ago #

    I have check and hyphenated words are working. Unfortunately, using the ' have to be encoded to be added to the database, and it won't work unless you use some other character.

    How many links you added trough the import ? You got that error when the file was being imported ?

  10. Dirty Bill
    Member
    Posted 9 months ago #

    I found that error in the logs while the site was running.

    The import was done a month or so ago. The import was 145 items. No problem with the ' character, I've got a solution working.

  11. thedark
    Member
    Plugin Author

    Posted 9 months ago #

    It was an one time error or it appeared many times ? Please let me know if it appears again.

    What solution do you have for the other problem ?

  12. Dirty Bill
    Member
    Posted 9 months ago #

    It happened 3 times in succession, then I had to turn it off, it was killing the site load. I'll turn it back on and test. With the "'" issue, We are just using Anthony Thomas instead of De'Anthony Thomas. Not very high tech, but it works. So does the hyphen fix btw.

  13. Dirty Bill
    Member
    Posted 9 months ago #

    The error is persistent. Server is running Debian Wheezy, PHP5.4.4

  14. thedark
    Member
    Plugin Author

    Posted 9 months ago #

    Can you send me the error that you get, and if you can, an export file with the links that you have inserted ?

  15. Dirty Bill
    Member
    Posted 9 months ago #

    Just installing your latest update, will activate and run. I'll paste it in here on next occurrence. You are one of the more responsive devs when it comes to problems - I appreciate the help.

  16. Dirty Bill
    Member
    Posted 9 months ago #

    Maximum execution time of 30 seconds exceeded in /wp-content/plugins/wp-auto-affiliate-links/aal_engine.php on line 84

    This is pretty consistent now. I can export and send you the file, need a place to send it.

  17. thedark
    Member
    Plugin Author

    Posted 9 months ago #

    Please send me an email to lucian [at] flamescorpion. ( com )

  18. thedark
    Member
    Plugin Author

    Posted 9 months ago #

    I didn't received your information yet.

  19. thedark
    Member
    Plugin Author

    Posted 9 months ago #

    Thank you for your help. Using your links I was able to reduce the loading speed by 10 times. The loading time required to replace the links was 700 miliseconds before ( using your links and a given article ). After the modification I was able to reduce the replacement speed to 50 miliseconds.

  20. Dirty Bill
    Member
    Posted 9 months ago #

    Glad to help, thanks for supporting your plugin. That's a big speed increase.

Reply

You must log in to post.

About this Plugin

About this Topic