WordPress.org

Ready to get started?Download WordPress

Forums

Broken Link Checker
Permanently "Searching your blog for links..." (4 posts)

  1. prodigi69
    Member
    Posted 10 months ago #

    On my WordPress 3.4.2 installation the Broken Link Checker plug-in permanently states:

    No broken links found.
    No URLs in the work queue.
    Searching your blog for links...

    It never seems to find any links, let alone check them. My setup is probably a little unusual in that my hosting platform is Microsoft Windows/IIS and Parallels Plesk rather than Linux/Apache/cPanel.

    My suspicion is that this may be a permissions problem on the server directories, but am not certain. Most of the debug info shows green, including the installation log. PHP & DB versions are as follows:

    PHP version 5.2.6
    MySQL version 5.0.45

    The debug items which show as yellow are...

    CURL version 7.16.0
    You have an old version of CURL. Redirect detection may not work properly.

    ...as well as the unparsed items and link records from the info below:

    Resynch. flag 1
    Synch. records 55
    Unparsed items 55
    Link records 0 (0)

    Any ideas what the issue might be, or how to perform further diagnostics?

    Many thanks in advance.

    http://wordpress.org/extend/plugins/broken-link-checker/

  2. David
    Member
    Posted 10 months ago #

    I had this problem and think I figured it out. In the Settings, under the Advanced tab, check the Server Load Limit setting. Mine was preset to 4 after installing the plugin, but my server was constantly running at about 50... maybe because I'm on shared hosting. I simply removed that value so there was no load limit, and now the plugin is working!

  3. pugh
    Member
    Posted 9 months ago #

    Thanks for this answer David,

    I was having the same problem and hadn't thought of this, but it solved the error for me.

  4. prodigi69
    Member
    Posted 9 months ago #

    Thanks for the suggestion, and sorry for the delayed reply. Your premise may well be correct, since it worked for pugh666. Unfortunately my WP is hosted on Windows IIS, and the option in advanced settings is disabled (apparently only available on Linux). Time to look at moving to a LAMP based host perhaps!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.