WordPress.org

Ready to get started?Download WordPress

Forums

Permanently disabling WYSIWYG Editor (11 posts)

  1. Joni
    Member
    Posted 8 years ago #

    Is this possible? I have unchecked the box "use the visual rich text editor when writing" and still the darn thing comes up. I'd prefer it default to plain old HTML. (Behavior in IE6 and Firefox, BTW.)

  2. Michael Bishop

    Posted 8 years ago #

    joni, have you tried dumping your cache? I know I had some serious issues with my wp.com (which was running 1.6alpha) and FF 1.5 until I emptied the cache, and then it seemed fine.

  3. Joni
    Member
    Posted 8 years ago #

    Aack. I tried clearing cache in both IE6 and Firefox and the WYSIWYG editor pops up by default. I have to click the "HTML" button to get the HTML editor to load in a popup window. (And I also then have to remember to hit "Save" after I hit the "Update" button on that HTML window.)

  4. masquerade
    Member
    Posted 8 years ago #

  5. Matt Mullenweg
    Troublemaker
    Posted 8 years ago #

    You shouldn't need a plugin. If you uncheck the box on your profile page the WYSIWYG should never show up. If not, please help us find the bug.

  6. Joni
    Member
    Posted 8 years ago #

    Hi, Matt. What other facts would you need to help squash this particular bug?

  7. Beel
    Member
    Posted 8 years ago #

    Go into "Users" and deselect it there (at the bottom). Evidently the Options|Writing selection is the default option for new users, but the override is in user options.

  8. Joni
    Member
    Posted 8 years ago #

    Beel, once again, you are my Knight in Shining Armor! Worked like a charm, although it would seem an unlikely place to put something like that, especially since there's the other (confusing) checkbox elsewhere!

    This goes a long way toward making 2.0 tres kewl in my book! I'm a simple girl and I like simple things, good old HTML!

    ;-)

  9. Beel
    Member
    Posted 8 years ago #

    I knew about it because that was the very first thing I went looking to disable. It is a good place to have it since it is individually selectable, but the option could be clearer...

    "Visual rich editor as default for writing"
    or maybe
    "Default to visual rich editor for writing (override in User options)"

  10. vkaryl
    Member
    Posted 8 years ago #

    If you wait long enough, someone will provide the answer.... thanks all! Thought I was losing my mind, but didn't seem that I needed to do a bunch of "me too-ing"....

    Well, at least it's NOT a bug! Thanks Beel - again!

  11. jcdesign
    Member
    Posted 8 years ago #

    Okay, Owen's Admin Revert plugin seems more permanent than I expected. I tried it to see if it looked better (in WP 2.0, and I re-read it, and it says it's a WP 1.6 plugin, but hey, mistakes were made) and it got rid of a lot of annoying cruft in the Write Page interface. Too much, as a matter of fact.

    So, I disabled the plugin.

    And I refreshed the Write Page page, and the missing fields were still missing. I refreshed a couple of more times to be sure. Still missing.

    Then I deleted the plugin.

    The fields are still missing.

    I cleared the cache...

    You guessed it, the fields (such as parent page, post slug, and more) are not anywhere to be seen.

    Yarr.....

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.