WordPress.org

Ready to get started?Download WordPress

Forums

Permanent Link and .htaccess (20 posts)

  1. Anonymous
    Unregistered
    Posted 9 years ago #

    I've tried to create a new .htaccess file an put it into the blog directory. I reorganized my permanent links and insert the content wordpress gave me into the .htaccess file... but now I can't get access to my wordpress anymore.
    "You don't have permission to access /blog/index.php on this server."
    what is wrong with my .htaccess file?!

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Download your .htaccess, then DELETE it from the server.
    The permalinks code that WP gave you does not and will not cause that error - there must be extra content in there.

  3. Anonymous
    Unregistered
    Posted 9 years ago #

    what extra content? what can I do to make it works?

  4. Mark (podz)
    Support Maven
    Posted 9 years ago #

    The WordPress permalinks cannot lock you out of your own blog - that would be daft :)
    Paste the .htaccess here ?

  5. Anonymous
    Unregistered
    Posted 9 years ago #

    I didn't had a .htaccess in the root of my blog. I created a new .htaccess file and just filled it with the code WP gave me.

  6. Mark (podz)
    Support Maven
    Posted 9 years ago #

    I can't help unless I can see both the .htaccess you created, and any other .htaccess files you have, and you say where they are in your webspace.

  7. Anonymous
    Unregistered
    Posted 9 years ago #

    so, there is no .htaccess file on my server. and the file I created just contained:
    RewriteEngine On
    RewriteBase /blog/
    RewriteRule ^index.php/archives/category/(.*)/(feed|rdf|rss|rss2|atom)/?$ /blog/wp-feed.php?category_name=$1&feed=$2 [QSA]
    RewriteRule ^index.php/archives/category/?(.*) /blog/index.php?category_name=$1 [QSA]
    RewriteRule ^index.php/archives/author/(.*)/(feed|rdf|rss|rss2|atom)/?$ /blog/wp-feed.php?author_name=$1&feed=$2 [QSA]
    RewriteRule ^index.php/archives/author/?(.*) /blog/index.php?author_name=$1 [QSA]
    RewriteRule ^index.php/archives/?([0-9]{4})?/?([0-9]{1,2})?/?([0-9]{1,2})?/?([_0-9a-z-]+)?/?([0-9]+)?/?$ /blog/index.php?year=$1&monthnum=$2&day=$3&name=$4&page=$5 [QSA]
    RewriteRule ^index.php/archives/?([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([_0-9a-z-]+)/(feed|rdf|rss|rss2|atom)/?$ /blog/wp-feed.php?year=$1&monthnum=$2&day=$3&name=$4&feed=$5 [QSA]
    RewriteRule ^index.php/archives/?([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([_0-9a-z-]+)/trackback/?$ /blog/wp-trackback.php?year=$1&monthnum=$2&day=$3&name=$4 [QSA]
    RewriteRule ^feed/?([_0-9a-z-]+)?/?$ /blog/wp-feed.php?feed=$1 [QSA]
    RewriteRule ^comments/feed/?([_0-9a-z-]+)?/?$ /blog/wp-feed.php?feed=$1&withcomments=1 [QSA]
    I've put it in the root of my blog.

  8. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Comparing first lines:
    Yours:
    RewriteRule ^index.php/archives/category/(.*)/(feed|rdf|rss|rss2|atom)/?$ /blog/wp-feed.php?category_name=$1&feed=$2 [QSA]
    Mine-
    RewriteRule ^archives/category/(.*)/(feed|rdf|rss|rss2|atom)/?$ /T2/wp-feed.php?category_name=$1&feed=$2 [QSA]
    Try taking 'index.php' out of each line ?

  9. Anonymous
    Unregistered
    Posted 9 years ago #

    I just tried it.. doesn't work :/

  10. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Does you host have mod_rewrite enabled ?

  11. Anonymous
    Unregistered
    Posted 9 years ago #

    how can I find it out?

  12. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Either mail them, or paste this into Notepad
    <?php phpinfo(); ?>
    Save it as 'phpinfo.php' Upload it to your webspace, then go to that file in your browser - http://www.example.com/phpinfo.php - and look through the info that is generated.

  13. Anonymous
    Unregistered
    Posted 9 years ago #

    under "loaded modules" mod_rewrite is listed.

  14. Mark (podz)
    Support Maven
    Posted 9 years ago #

    What I suggest is that you take the .htaccess out, and give us a link to your site.
    Then when we see it works, you put it back, and we see what happens ?

  15. Anonymous
    Unregistered
    Posted 9 years ago #

    okay! the URL to my blog is: http://blog.klepto.de
    the .htaccess file is deleted now!

  16. Anonymous
    Unregistered
    Posted 9 years ago #

    as you can see, the links for RSS don't work.. that's my problem. I thought about deleting my permanent link structure, but are there any disadvantages without a permanent link structure?

  17. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Permalinks give nicer results in search engines apparently :)
    Try putting the .htaccess back ?

  18. Anonymous
    Unregistered
    Posted 9 years ago #

    hm, I did it... :/

  19. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Hmmm ... yea ..... not nice.
    Error 403 - Forbidden
    "You don't have permission to access / on this server."
    A reference page on this:
    http://www.checkupdown.com/status/E403.html
    I really don't think this is a WP error, but more related to your host. I would email them, with a copy of your .htaccess, and ask them for help.

  20. Anonymous
    Unregistered
    Posted 9 years ago #

    okay, thanks for everything! temporarily I will work without permalinks, so the RSS feed works.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.