WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks/.htaccess problem - .htaccess not being modified (7 posts)

  1. samanime
    Member
    Posted 6 years ago #

    Hello,

    I'm trying to set up a permalink structure like this:
    %category%/%postname%

    That is simple enough.

    However, it isn't wanting to work. It looks like the .htaccess file isn't being changed. Regardless what I set it to, the .htaccess only contains this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    which makes no reference to the permalink structure. When I save the changes, it says it was successfully updated. If I delete the file, it will generate a new one when I save, but it will only contain that code.

    Any ideas? Thanks.

  2. whooami
    Member
    Posted 6 years ago #

    wordpress rewrites are internal. dont look at the .htaccess, look to see if you are getting the desired permalink structure.

  3. samanime
    Member
    Posted 6 years ago #

    It's started working now. I just kept doing the same thing and now it works. The .htaccess is still the same though. Can anyone explain how the permalink thing works? I figured it'd have to update my .htaccess file in order for it to work.

  4. Roy
    Member
    Posted 6 years ago #

    Did you read this?

  5. samanime
    Member
    Posted 6 years ago #

    Yes, I did, and that page says that it modifies the .htaccess (or at least that's what I interpreted from that page).

  6. whooami
    Member
    Posted 6 years ago #

    permalinks are internal now, like I already wrote.

    this site, for instance,

    http://www.pajamadeen.com

    here is her .htaccess:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Internal.

    2.5.x and starting somewhere below that, maybe 2.3.x ALL wordpress writes to your .htaccess is THAT. Everything else is handled internally.

    There is a whole file dedicated to it.
    wp-includes/rewrite.php

  7. neononcon
    Member
    Posted 5 years ago #

    for anyone having issues with this. make sure your htaccess is writable before saving the permalink settings in admin. if you dont know how to do it, go to your ftp (such as fireftp firefox extension) and right click to select properties, then check the boxes until the permission level is like 777. If you can't see your htaccess, go to tools>options>general (first tab) and check the box that lets you see hidden files. Now your htaccess will be visible - so do raise the permissions like I already explained.

    Then go back to your wp admin and save the permalink settings you want. Now you can go back to your ftp and lower the permissions on your htaccess to like 644. now your permalinks should work.

Topic Closed

This topic has been closed to new replies.

About this Topic