WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks work for Posts but not for Pages (6 posts)

  1. s1ade
    Member
    Posted 6 years ago #

    Hi, permalinks works great for all my posts. However, it sends me to a Error 404 Page Not Found when I try to go to a page. I've had this problem for a while, but in WP 2.2 I found a work around. I just linked to my pages using the default address (i.e. http://photopics.ca/tom/?page_id=4)

    But after I upgraded to WP 2.3, when I go to the default link, it redirects to the permalink, which does not work.

    My blog at http://www.photopics.ca/tom/ on the right hand side I have three pages listed:
    * About Me
    * Contact Me
    * Canadian Blawgs
    That will give you an example of my problem. You can also see that the permalinks work fine for the posts.

    Anyone have an idea of a possible solution? All the other threads I've checked only have people who have problems with BOTH posts and pages, not just pages alone. I was happy enough with my old workaround, any way to get that working again if there isn't a proper fix?

    I had an old thread (http://wordpress.org/support/topic/131872?replies=13) on this issue, but I think since the upgrade, my problem has slightly changed with the "URL handling improvements"

    Thanks!

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Try updating your permalink structure in Options->Permalinks. Just click the button so that it will rebuild internally.

  3. s1ade
    Member
    Posted 6 years ago #

    Hmm doesn't seem to change anything. I logged in, made a new page http://www.photopics.ca/tom/ballin-with-23/, then went to Options->Permalinks and updated. And I still get the same message.

  4. s1ade
    Member
    Posted 6 years ago #

    Well I came up with another, somewhat obvious workaround. I just converted all my pages to posts and timestamped them with an old date. Then in my sidebar I have an php widget that lets me just put in my own hyperlinks to the posts.

  5. edwinkort
    Member
    Posted 6 years ago #

    I hope there will be a beter solution for this soon. I love WP because of it's permalinks.

  6. baggagecarousel4
    Member
    Posted 6 years ago #

    i am having the same problem, and since upgrading from 2.2, the workaround i used (same as the original poster in this thread) no longer works. what gives? this is seriously horking my blog up.

Topic Closed

This topic has been closed to new replies.

About this Topic