WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalinks won't work - I'm stumped! (6 posts)

  1. rudiegirl
    Member
    Posted 7 years ago #

    I just started running WP 2.0.4 on a fresh install and tried to activate my permalinks, but as soon as I do that, it breaks my site. None of the permalinks work and none of the pages work.

    I checked with my host, and mod_rewrite is installed and enabled on our server.

    My .htaccess file has permissions set to 666, so it should be writable by WP.

    My .htaccess file reads like this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /sovery/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /sovery/index.php [L]
    </IfModule>

    # END WordPress

    Here's the site: http://www.ktuh.org/sovery

    I'm not using frontpage or anything like that.

    I'm stumped.

  2. moshu
    Member
    Posted 7 years ago #

    Now it set to default structure.
    What was the permalink structure you tried to set?

  3. rudiegirl
    Member
    Posted 7 years ago #

    This is what I wanted to set it to:

    Date and name based
    ยป http://www.ktuh.org/sovery/2006/08/03/sample-post/

    But it broke the site so I set it back to default. I'm running another wordpress site elsewhere and the permalinks work fine on that one. The only difference is a)the server and b)the WP version (2.0.4)

    I'll post what the .htaccess file looks like after I change it back to the permalink structure I want. I don't suppose it makes any difference which of those choices I choose.

  4. Chris_K
    Member
    Posted 7 years ago #

    Have you glanced over ALL the troubleshooting tips on the Permalinks codex page?

    In particular: Have you confirmed with your web host that they have mod_rewrite -and- AllowOverrides enabled and on?

  5. rudiegirl
    Member
    Posted 7 years ago #

    I confirmed with my webhost that mod_rewrite is installed and enabled. He is checking now about AllowOverride.

    I read on that Using Permalinks page that some of these errors can also mess up pagination. The "Previous Entries" and "Next Entries" links on the bottom of my index page don't work. But they don't give an error either. Instead, it just reloads the same content into the page.

    Thanks for your help!

  6. rudiegirl
    Member
    Posted 7 years ago #

    It looks the same after I change it back to permalinks:


    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /sovery/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /sovery/index.php [L]
    </IfModule>
    # END WordPress

    Which tells me the AllowOverride is probably not enabled. *crosses fingers* I hope that's it!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags