WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks won't work (5 posts)

  1. westpointer
    Member
    Posted 9 years ago #

    Greetings!

    Here are my settings:

    WordPress 1.5.1.1
    Apache 2.0
    Suse 9 Enterprise Server
    PHP 4.3.4

    I have a valid .htaccess file. I've made sure that mod_rewrite is loaded.

    In my httpd.conf file, I have this:
    ---------------------------------
    # forbid access to the entire filesystem by default
    <Directory />
    Options None
    AllowOverride None
    Order deny,allow
    Deny from all
    </Directory>

    <Directory /wordpress/>
    AllowOverride All
    </Directory>

    # use .htaccess files for overriding,
    AccessFileName .htaccess
    # and never show them
    <Files ~ "^\.ht">
    Order allow,deny
    Deny from all
    </Files>

    ------------

    But when I try the default permalink example, the page is not found. If I add /index.php/ to the front of the permalink it works, but I don't really want that.

    Any ideas? Does my httpd.conf look right?

    Thanks!

  2. Michael Adams (mdawaffe)
    Member
    Posted 9 years ago #

    Is your WordPress installation really in /wordpress and not something like /var/www/blah/blah/wordpress or /home/....../wordpress ?

    It may be, in which case this is just an annoying silly question, but even silly things are worth checking.

  3. westpointer
    Member
    Posted 9 years ago #

    oh ... crap ... the silly simple things are what get you. Of course it is not in /wordpress except relative to the docroot. I'll make that change and see if it helps. thanks!

  4. westpointer
    Member
    Posted 9 years ago #

    Correcting the path did the trick. Thanks!

  5. Michael Adams (mdawaffe)
    Member
    Posted 9 years ago #

    Awesome. Glad it works.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.