WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks Won't Pretty (9 posts)

  1. happinesshabit
    Member
    Posted 7 years ago #

    HELP! The permalinks for HappinessBlog.com will not turn pretty. I'm running it at 1and1.com on Linux and have followed the instructions carefully. I am new to WordPress. This is what I've done...

    I changed htaccess to 666 and added
    Options +FollowSymLinks
    RewriteEngine On
    RewriteBase /
    to the htaccess file

    then put this line in the Permalinks Custom
    /archives/%year%/%monthnum%/%day%/%postname%/

    every time I tried to put
    http://happinessblog.com/archives/%year%/%monthnum%/%day%/%postname%/

    into the Custom Line it moved the / to the front of the line like this:

    /http:/happinessblgo.com/archives/%year%/%monthnum%/%day%/%postname%/

    which bombs out with a 404 error code. When I just put

    /archives/%year%/%monthnum%/%day%/%postname%/

    in it works okay but no pretty permalinks!

    And when I tried the index.php option that did not get me pretty permalinks either. I'm clearly missing something...
    PLEASE HELP!!!! You are marveous!

  2. Andrew Ozz
    WordPress Dev
    Posted 7 years ago #

    I'm not exactly sure what you mean by "pretty", but your permalinks seem to be working ok. Or perhaps you've already fixed them?

  3. kanute
    Member
    Posted 7 years ago #

    well you could just add .html to end to make it look pretty. its an illision but it works. just do this

    /archives/%year%/%monthnum%/%day%/%postname%/.html

  4. rudolf45
    Member
    Posted 7 years ago #

    On the permalinks setting page you should never put the URI (/http:/happinessblgo.com/) in any field!

  5. happinesshabit
    Member
    Posted 7 years ago #

    Thanks for your comments, but the permalinks do NOT show post date or name, that's what I want really want to achieve for SEO.

    See, here's what I put in the Custom Structure Line:
    /archives/%year%/%monthnum%/%day%/%postname%/

    and using index.php did not bring them up as well. All I get is archive/year/month - that's not a complete pretty permalink like what's described in the WordPress SEO suggestions.

    The day and post name are in the files somewhere, for some reason they are not being picked up and displayed as the examples show.

    PLEASE HELP!!! Many thanks...

  6. rudolf45
    Member
    Posted 7 years ago #

    You may want to clear your cache - all your permalinks work for me.

  7. Andrew Ozz
    WordPress Dev
    Posted 7 years ago #

  8. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    Same here. All the permalinks I checked are working fine.

  9. happinesshabit
    Member
    Posted 7 years ago #

    VBG ;-) Oouch! Thanks so much, I said I was new... Blessings to all of you!

Topic Closed

This topic has been closed to new replies.

About this Topic