WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks won't display entries > 999 if not using a date structure (3 posts)

  1. zeno
    Member
    Posted 9 years ago #

    Searched and didn't see any mention of this, so I hope I'm not being repetitive, but I'm using permalinks of type "/entry/%post_id%", which is distinct from "/archives/%year%/%month%/%day/" in order to provide quick, easy links. However, WordPress does not have an option to let entries have a different string then archives, so it bunches everything under "/archives/" and if I have a post_id of > 999, it thinks it is a year and gives a 404. Note that even though I do *not* specify how to handle things like %year%, etc., they are still taken care of by WordPress. Which is neat, but a little weird.

    The obvious solution to this is to fix the .htaccess (and links in various places) manually, which is how I had it in 1.2 (I guess...), but now with the wonderful ability to overwrite .htaccess automatically when I do things like create new pages, this doesn't really work. I can't imagine I am the only person who uses this type of structure...am I? Just like there is a field for "Category base" it would be neat to have an option for a different structure for individual entries vs. archive links. Or does everyone disagree completely? (Hey, it's all about choice, right?)

  2. pericat
    Member
    Posted 9 years ago #

    As a bandaid, you might try changing the permissions on your .htaccess file to '644'. This should prevent auto-updating on the part of the WP engine.

    Of course, it also seems to trash page creation. :(

  3. Ryan Boren
    WordPress Dev
    Posted 9 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.