WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalinks with WPG2 plugin installed (12 posts)

  1. kak
    Member
    Posted 8 years ago #

    I've got problems with permalinks working with the WPG2-plugin installed. Without the WPG2-plugin installed the permalinks works just perfectly. I've running two blogs on the same server and configuration, one with WPG2 and one without WPG2. On the one with WPG2 installed, I'm just returned with a blank page if I try to click on a story or page (when a nice permalink is configured, the only one that works is the default one) on the blog with the WPG2-plugin installed. On the other blog without the WPG2-plugin installed everything works perfectly.

    Does anyone have this problem or/and have fixed the problem?

    Yes, the .htaccess file is writeable and include both code from WordPress and WPG2.

  2. kak
    Member
    Posted 8 years ago #

    This is the .htaccess from the site with WPG2:

    # BEGIN Url Rewrite section
    # (Automatically generated. Do not edit this section)
    <IfModule mod_rewrite.c>
    RewriteEngine On

    RewriteBase /

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d [OR]
    RewriteCond %{REQUEST_FILENAME} gallery\_remote2\.php
    RewriteCond %{REQUEST_FILENAME} !/wp-gallery2\.php$
    RewriteRule . - [L]

    RewriteCond %{QUERY_STRING} view=core.DownloadItem
    RewriteCond %{HTTP_REFERER} !://prat.kak.net/ [NC]
    RewriteCond %{HTTP_REFERER} !://blog.kak.net/ [NC]
    RewriteCond %{HTTP_REFERER} !://blog.kak.net/ [NC]
    RewriteCond %{HTTP_REFERER} !://gallery.kak.net/ [NC]
    RewriteCond %{HTTP_REFERER} !^$
    RewriteRule . /wp-gallery2.php? [F,L]

    RewriteCond %{THE_REQUEST} \ /d/([0-9]+)-([0-9]+)/([^\/\?]+)(\?.|\ .)
    RewriteCond %{REQUEST_FILENAME} !/wp-gallery2\.php$
    RewriteRule . /main.php?g2_view=core.DownloadItem&g2_itemId=%1&g2_serialNumber=%2&g2_fileName=%3 [QSA,L]

    RewriteCond %{THE_REQUEST} \ /([^?]+)(\?.|\ .)
    RewriteCond %{REQUEST_FILENAME} !/wp-gallery2\.php$
    RewriteRule . /wp-gallery2.php?g2_view=core.ShowItem&g2_path=%1 [QSA,L]

    </IfModule>

    # END Url Rewrite section

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  3. kak
    Member
    Posted 8 years ago #

    This is the .htaccess from the site without WPG2:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  4. kak
    Member
    Posted 8 years ago #

    No one have had or have this problem?

  5. kak
    Member
    Posted 8 years ago #

    That's strange. Does anyone else using WP and WPG2 here and have the permalinks working just fine? If so, how is your .htaccess file?

    Thanks in advance!

  6. kak
    Member
    Posted 8 years ago #

    If I replace the .htaccess (for the site with WPG2 installed) without the WPG2-related stuff inside, permalinks works just fine. But WPG2 doesn't work of course. So it's certain that the .htaccess file is read.

    What is it with the WPG2-related stuff in the .htaccess who fuck up the permalinks in WP?

  7. zenandjuice
    Member
    Posted 8 years ago #

    I'm getting the exact same error on a site.

  8. Aylwin
    Member
    Posted 7 years ago #

    I would suggest posting here: http://www.galleryembedded.com/forums/

  9. Conal
    Member
    Posted 7 years ago #

    All I get is blank page too =\

  10. kak
    Member
    Posted 7 years ago #

    I've tried out something new on another site (same hosting company) .. if you use permalinks on WP but not mod_rewrite on gallery2, the permalinks in WP works fine. But I want them both to work! :(

  11. kak
    Member
    Posted 7 years ago #

    The problem and the solution was simple. I've changed the mod_rewrite for G2 back to default, and everything works perfectly. The change I had done was to change the "show item" url rewrite from "v/%path%" to "%path%". Now when it's "v/%path%" again, everything works perfectly!

  12. akiwitz
    Member
    Posted 7 years ago #

    Hi kak,

    i have the sam problem. But in the setting, when i want to migrate vom g1 to g2 i have to use "%path%" as it's greyed out. So i can't change the path to something else. can anybody help?

    thank you,

    andre

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.