WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalinks, urls and slugs (6 posts)

  1. bdown111
    Member
    Posted 3 months ago #

    Hi,

    I'm a newbie (sorry). I've seen this topic a few times, but I haven't seen a solution that I can understand.

    My site basically has three levels of pages: home page, level 2, level 3.

    My understanding is that the home page is the parent page to level 2, and level 2 is the parent page to level 3. So for a level 3 page, the url will be "home/Illinois/Chicago" for example.

    How do I structure the permalink so that "home" doesn't show in the url? I want the hierarchy intact so that my breadcrumbs will work correctly (I'm using Suffusion theme), but I don't want the word "home" in my page url.

    I really appreciate any help anyone can provide. It's probably simple, but it's got me really confused.

    I thank you in advance.

  2. gerald@WPcustoms
    Member
    Posted 3 months ago #

    you need to set the parent and child relation on the page edit screen. (there is a dropdown on the right tab)
    permalinks get automatically adjusted to follow that structure
    https://codex.wordpress.org/Pages#Organizing_Your_Pages
    http://headwaythemes.com/using-parent-pages-and-wordpress-menus-effectively/

    also set your HOME page as the frontpage here: settings -> general so it won't appear in the URL.

  3. bdown111
    Member
    Posted 3 months ago #

    Hi Gerald,

    Thanks for the reply. I read the codex and I believe I have been setting up the pages correctly. "Home" is parent to the level 2 page and level 2 is parent to level 3, right?

    But, instead of the "www.example.com/home/Illinois/Chicago",
    I would like the url to read "www.example.com/Illinois/Chicago". (getting rid of "home" in the path.) Does that make sense?

    Again, I thank you for any help you can provide.

  4. bdown111
    Member
    Posted 3 months ago #

    By the way, I'm using the "post-name" setting in the permalinks:
    http://example.com/sample-post/, if that helps.

  5. gerald@WPcustoms
    Member
    Posted 3 months ago #

    "Home" is a parent page with no childs.
    Set your level 2 (illinois) also as a parent page with level 3 (chicago) as the child page of level2

    so you get:
    * home
    * illinois
    - chicago

    permalinks are correct.

    Set HOME page as the frontpage here: settings -> general so it won't appear in the URL.

  6. bdown111
    Member
    Posted 3 months ago #

    Thanks Gerald. I was getting hung up thinking that level 2 had to be the child of the home page rather than a main/parent page of its own!

    I appreciate your help.

Reply

You must log in to post.

About this Topic