WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks suddenly work no more (7 posts)

  1. orangeguru
    Member
    Posted 8 years ago #

    Very strange - I have my own server with currently two WP 1.5.2 blogs running on it. They have been working fine - until 1 hour ago.

    Suddenly in both cases the permalinks won't work anymore:

    If I try if access an entry via it's permalink URL:

    http://www.orangeblog.net/2005/10/23/duane-michals-the-sorcerers-apprentice/

    It won't work.

    I still can access the entry via it's Post ID:

    http://www.orangeblog.net/?p=100

    I already looked at the permalink entry at the Codex and checked my server settings, but everything still is as it used to be for the last three month - no changes to be found, no updates, no changed software.

    http://codex.wordpress.org/Using_Permalinks

    Checked the .htaccess entries and even recreated them. Nope. Same ol' problem. The backend is still working fine, also my other web apps like bbClone:

    http://www.orangeblog.net/bbclone/show_views.php?id=4247&lng=en

    Any ideas why my permalinks fail or anything I could check?

    :-(

    Thanks for your help.

  2. Is mod_rewrite still running?

  3. Actually, it looks like your permalinks are no longer set on your blog. Have you tried setting them again in Options/Permalinks?

  4. orangeguru
    Member
    Posted 8 years ago #

    macmanx - thanks for the quick reply.

    Hmm. Can' remember ever switching it off / uninstalling it. Any way to check if it is working / installed?

    Thanks again.

  5. orangeguru
    Member
    Posted 8 years ago #

    ;-)

    Yep. I just kille permalinks, deleted the htaccess and recreated it - same ol' problem.

  6. orangeguru
    Member
    Posted 8 years ago #

    Hmmm. Mod_rewrite is running. Even checked if Symlinks ar allowed - yep:

    <Directory />
    Options FollowSymLinks
    AllowOverride All
    </Directory>

    Still no permalinks. Very weird.

  7. lodar
    Member
    Posted 8 years ago #

    Hi!
    The same problem appeared with my wordpress last week. Evetything was fine for one year too.
    I've tried everything.
    Finally i've tried to remove the last slash (after the %article-name%) from the permalink template and that helped.
    But now i still can't use the calendar, because clicking the day you get link like "...archives/2005/12/13/" or month - "...archives/2005/12/" and browser shows
    <i><b>Forbidden</b>
    You don't have permission to access /archives/2005/12/12/ on this server.
    ...</i>
    But the date will be shown on removing the last slash from your adress bar of the browser.

    So how to fix such problem with permalinks? What's the matter?

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags