WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalinks Stopped Working After Upgrade to 3.6.1 (6 posts)

  1. clake
    Member
    Posted 11 months ago #

    Before upgrading to 3.6.1, my permalinks worked as configured (set to Post Name setting). After the upgrade, any new posts use the Default setting instead even though Post Name setting is still selected.

    Post Name setting is: http://window-data.com/sample-post/

    Default setting is: http://window-data.com/?p=123

    I have made NO customizations to my .htaccess file.

    Please advise. I'm due to publish another blog post today, but am stopped until this is fixed.

  2. KrissieV
    Member
    Posted 11 months ago #

    I would try going to the settings page and clicking save again on the correct setting. I'm pretty sure WordPress updates the .htaccess file every time you save on that page, so if something got askew, that should correct it.

  3. clake
    Member
    Posted 11 months ago #

    Yeah, tried that several times. No joy. I even tried setting it to Default and then switching it back to Post Name. That didn't work either.

  4. clake
    Member
    Posted 11 months ago #

    Actually, I just looked at it again. The permalink is fine. It's the link that is used by the All in one SEO pack that's the issue . . .

  5. clake
    Member
    Posted 11 months ago #

    O.k. just figured it out. So, although the draft of the blog post has been saved and although the All in One SEO Pack is reading the value for the permalink, for some reason, it looks like WordPress stores the default permalink value in the database until the post is published. Once the post is published, the value in the SEO Pack tool displays correctly. Mystery solved!

  6. clake
    Member
    Posted 11 months ago #

    Closing.

Reply

You must log in to post.

About this Topic

Tags