WordPress.org

Ready to get started?Download WordPress

Forums

permalinks show names of long deleted pages (6 posts)

  1. notknow
    Member
    Posted 4 years ago #

    I switched to permalinks today and first everything seemed to be fine. After a while i realized that some of the permalinks use names of pages long deleted (not listed in the backend anymore). The link points to a non existent pagename but WordPress still finds the right page (with the wrong name in the url), displays it and the highlighting of the navigation also works.

    Other side effects: all images are gone (not in the source, but they are not displayed) and it takes about 20 seconds until a page has loaded completely (before: about 1-2 seconds).

    The number of posts dealing with permalink issues is overwhelming yet i coudn't find anything yet dealing with the above. Letting WordPress create a new .htaccess didn't help (that's what one would have supposed anyway).

    The only place where these pagenames still exist is the database. Is there a way to clean the wp_posts table and just keep what still is effectively in use (public & private)? I tried this once manually - ending up with the need of reinstalling.

    The missing images indicate that some manual adjustment has to be done. Ok then, i didn't search on this one yet.

    Any ideas about the "old pagename in permalink" thing and getting rid of all these entries in wp_posts table?

  2. notknow
    Member
    Posted 4 years ago #

    I searched for one of the old pagenames in wp_posts and deleted the entry.
    The old pagename still appears in a link.

    I then searched for the old pagename over the whole database and deleted anything phpmyadmin found. I assume i have deleted any occurance of one of these old pagenames in the database (and probably even more so the whole thing is already destined for deletion).
    The old pagename still appears in a link.

    And even if it had worked this way, that's not a proper solution. Why can't "delete" be "delete" or at least set posts inactive in a way it does not interfere with the rest? Starting to hate this (i know this vanishes but by now...)

  3. notknow
    Member
    Posted 4 years ago #

    Nothing found, Summary:

    Backend ->Options -> Permalinks:
    Switched from Standard to Custom (/%category%/%postname%/)

    Result:

    - images do no longer display

    - names of pages long deleted (now even in the database) are used to form the permalink, but the correct page loads

    - loading of pages takes up to 20 seconds with about 6 or 8 httpd-instances using nearly a hundred percent of available RAM

    Wow.

  4. notknow
    Member
    Posted 4 years ago #

    Found the culprit for the wrong "page-names":

    It seems that changing a pages' page_title does not affect the post_name or slug?
    Can someone confirm this or were it unlucky circumstances? Because about 50% of my post_name entries are the original (old, no longer used) page_title entries but the page_title has changed since (due to "content development" which is not under my control).

    Do i have to adjust these every time by using phpmyadmin when a page_title is being altered? (I first cleaned wp_posts by using DELETE FROM wp_posts WHERE post_type = “revision”;)

    The other two facts still remain, system overload and no images.

  5. notknow
    Member
    Posted 4 years ago #

    I found out i misread something in "Using Permalinks « WordPress Codex.html". It's better to _not_ (i missed the "not") use /%category%/%postname% because of the way Worpress processes these internally. Better to use /%post_id%/%postname%.

    I changed that but up to now it only changes speed with pages one level below root. Some of these pages have sub-pages on which nothing changed so far, they load extremely slow, no images are shown.

    Might add that all said above belongs to "pages", not "posts". Tried to open a post with the permalink settings mentioned above (%post_id%/%postnam), they are messed up also, they behave now as if they were _not_ single, ie the text is truncated after the <!--more-->, with other words, is_single() does not work anymore as expected.

    Anyone having a bit of an idea what might be to do - please drop me a line, i'm into this for three days now and really running out of ideas what to do.

  6. notknow
    Member
    Posted 4 years ago #

    Uiuiui,

    starting to see a little bit clearer, am i hitting a sore point of WordPress?

    I followed the discussion metioned in Using Permalinks « WordPress Codex.html.

    That's not funny.
    Especially the speed-thing. Using the year at first place for a custom permalink-structure is all good and well as long as it makes sense for most of the content to be sorted that way. The more CMS-style the whole thing gets the lesser this is the case. And by now it seems to me that the solution does not at all speed up the whole thing if many pages (well, "many", it seems about 30 are enough) are involved (the year does not appear in the link then which makes me think the whole bunch of rewrite-rules has to be processed when calling pages using permalinks).

    Bumm. And clueless (still).

    (i know, i know, there's more info to be found than i first thought, nevertheless solutions seem to be rather rare - but they always appear at the end of such journeys (hope so)).

Topic Closed

This topic has been closed to new replies.

About this Topic