WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks settings page is blank (11 posts)

  1. DebbieV
    Member
    Posted 3 years ago #

    I'm setting up a new site.
    I want to have permalinks, instead of page ids.

    Using the menu at the left side of the screen, under "Settings"
    I click on "Permalinks"

    And the page that loads is blank.

    Please help!

    Thanks,
    :-D

  2. DebbieV
    Member
    Posted 3 years ago #

    THANKS!

    After reading all the replies above, to maybe save others some time:
    FIRST TWO TRIES DID NOT FIX IT:
    1. going into the database, and changing the "permalink structure" field in the wp_options table - didn't do anything for me. I changed it back to the original values.
    2. I did NOT do anything with an .htacess file.

    THIRD TRY WORKED LIKE A CHARM:
    3. I edited wp-admin/includes/misc.php, forcing the value of $got_rewrite = true;

    And that fixed it. Permalink page is no longer blank.

    Thanks ipstenu!
    :-D

  3. mdelassio
    Member
    Posted 3 years ago #

    Debbie,

    In regards to your post above on #3, is this what the value should look like when you say you forced? -thanks for you help.

    function got_mod_rewrite() {
    $got_rewrite = apache_mod_loaded('mod_rewrite', true);
    return apply_filters('got_rewrite', $got_rewrite);

  4. MikeHaydon
    Member
    Posted 3 years ago #

    Awesome Debbie. Thanks SO much!

    @mdelassio, I changed the line which read

    $got_rewrite = apache_mod_loaded('mod_rewrite', true);

    to read

    $got_rewrite = true;

    and it worked perfectly. As I understand it, you are changing a conditional statement to an absolute one by doing this.

  5. SweetThings
    Member
    Posted 3 years ago #

    Hi, as a total novice to wp and code, could someone explain to me where I find - wp-admin/includes/misc.php ? I gather that I need to change something there, but I don't know where to find it from my admin page/dashboard. All help would be appreciated.

  6. particks
    Member
    Posted 3 years ago #

    Thanks Debbie, great work!

  7. SweetThings
    Member
    Posted 3 years ago #

    Well I found where wp-admin/includes/misc.php is located. However I pasted in the suggested correction that Debbie tried, but to no avail. Now as I said previously I am a total novice, was there something else other than cut and paste and save the file that I should be doing? Thanking you all.

  8. Arcador
    Member
    Posted 3 years ago #

    I confirm,

    Solution number 3 worked for me as well.

    in the file:
    wp-admin/includes/misc.php
    edit
    $got_rewrite = apache_mod_loaded('mod_rewrite', true);
    to
    $got_rewrite = true;

  9. smashinghut
    Member
    Posted 3 years ago #

    DebbieV u r genius
    thanks so much for sharing your research

    i also confirm
    Solution number 3 worked for me as well.

    in the file:
    wp-admin/includes/misc.php
    edit
    $got_rewrite = apache_mod_loaded('mod_rewrite', true);
    to
    $got_rewrite = true;

  10. issaconan
    Member
    Posted 3 years ago #

    her it's in frensh solution translate with google to english :

    ""Vous avez un blog wordpress et vous obtenez une erreur 403 ou 500 après une modification des permaliens .

    La solution si vous avez PHPMyAdmin

    1>Connectez-vous à votre base de données
    2> Cliquez sur wp_options
    3> Trouvez permalink_structure 1ére ou 2éme page
    4> Cliquez sur le crayon
    5> Puis insérer /index.php/%postname%/ dans la zone adéquate et executer
    Pour free et les hébergeurs qui ne prennent pas en compte l'URL rewriting, il faut ajouter /index.php/

    Ensuite connectez-vous à la racine de votre blog grâce à filezilla ou autre, afin de supprimer le fichier .htaccess.
    Si vous ne voyez pas le fichier, cliquez sur l'option serveur en haut puis forcer l'affichage des fichiers cachés
    Ensuite supprimer le fichier et vous aurez de nouveau accès à votre blog !""

Topic Closed

This topic has been closed to new replies.

About this Topic