WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
Permalinks redirect event detail to calendar (8 posts)

  1. daymobrew
    Member
    Posted 3 years ago #

    Single event page does not work.

    Using EM 4.1.2 with WordPress 3.2 on Zeus/4.3 server on Linux. Zeus uses rewrite.script instead of .htaccess.
    I have deactivated and reactivated the plugin and refreshed my permalinks (month and name type). I have gone to Settings/Permalinks and clicked Save Changes.
    I have installed the permalink rewriter plugin in mu-plugins/em-perm-rewrite.php and run it.

    My calendar page is:
    http://www.irishtriathlon.com/index.php/event-detail/
    Individual pages have urls like:
    http://www.irishtriathlon.com/index.php/event-detail/event/credit-crunch-half-ironman-distance/
    but clicking on them brings me to the calendar page.
    I did create a 'Event' sub page of the 'event-detail' page but still does not work so I have deleted that sub page.

    Turning on EM_DISABLE_PERMALINKS gives working urls:
    http://www.irishtriathlon.com/index.php/event-detail/?event_id=14

    Any suggestions?

  2. daymobrew
    Member
    Posted 3 years ago #

    I have created a fresh install of WordPress 3.2.1 and EM 4.1.2. Using the default theme TwentyEleven. Permalinks set to Month and Name.

    http://em.irishtriathlon.com/index.php/events/
    Clicking on an event name returns to the events page.
    There is no change when I use a rewrite.script file (the Zeus equivalent of a .htaccess file).

  3. daymobrew
    Member
    Posted 3 years ago #

    I have been poking around classes/em-permalinks.php and the rewrite_rules row in the wp_options database table.

    My events page has a slug of /race-calendar/event-details (it is a sub page of the 'race-calendar' page.
    The rewrite_rules list has:
    s:49:"index.php/race-calendar/event-detail/event/(\d*)$"
    s:76:"index.php?pagename=index.php/race-calendar/event-detail&event_id=$matches[1]"

    This is exactly as I expect after reading line 127 in rewrite_rules_array() in em-permalinks.php but when I try a url of that format e.g.
    http://www.irishtriathlon.com/index.php/race-calendar/event-detail/event/31
    it goes to
    http://www.irishtriathlon.com/index.php/race-calendar/event-detail/
    instead of
    http://www.irishtriathlon.com/index.php?pagename=index.php/race-calendar/event-detail&event_id=31

    If I enter the latter url directly it gives a 404, after redirecting to:
    http://www.irishtriathlon.com/index.php/race-calendar/event-detail/?pagename=index.php/race-calendar/event-detail&event_id=31

    Should I move my Events page to the top level?

  4. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 3 years ago #

    you need to set EM_DISABLE_PERMALINKS to true in your wp-config.php file http://wordpress.org/support/topic/event-detail-links-not-working-latest-version-fresh-install

  5. daymobrew
    Member
    Posted 3 years ago #

    I have set EM_DISABLE_PERMALINKS to true in wp-config.php. This is the current setting on the live site.

    This gives me the 'ugly' urls. I want pretty permalinks. How do I achieve that? Can I achieve that on Zeus?

  6. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 3 years ago #

    not sure... however we're working towards making events posts so we're not tackling this issue as it'll fix itself

  7. daymobrew
    Member
    Posted 3 years ago #

    Interesting.
    Is this planned for version 5 or a v4 release?

    I will stick with EM_DISABLE_PERMALINKS = true for now.
    Thanks.

  8. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 3 years ago #

    i guess we'll have to call it v5 to avoid confusion.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic