WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks problem (I think) (8 posts)

  1. totallytech
    Member
    Posted 1 year ago #

    Hi Guys,

    I've got a site and I'm not 100% sure whats happening but all root level pages work but others dont.

    If I access:

    http://www.domain.com/home
    http://www.domain.com/albums
    http://www.domain.com/contact-us

    These work fine...

    If I access:

    http://www.domain.com/album/this-album
    http://www.domain.com/album/that-album
    http://www.domain.com/album/my-album

    I get a 404 error

    I'm thinking its a permalinks error but then I noticed that this:

    http://www.domain.com/galleries/my-gallery

    Works

    Any ideas where I should start?

    Also, this is a rebrand on my existing site, and I'm looking to change my url from http://www.domain.com/site to http://www.domain.com which I can do easily, but how do I tell google I've moved the url (so that the existing google listings still work) (possibly 301 redirect?

  2. totallytech
    Member
    Posted 1 year ago #

  3. totallytech
    Member
    Posted 1 year ago #

    to see my issue: http://goo.gl/B9GSu

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    Try resetting your custom permalinks back to the default setting via Settings -> Permalinks. If this works, then review Using_Permalinks before setting a custom permalink structure back up again.

  5. totallytech
    Member
    Posted 1 year ago #

    Esmi - Thank you :) I reset back to default and it worked!

    Then I reset to %postname% and now its broken again.... I checked the Using_Permalinks link in your post but %postname% is "correct"

    Must be something in the .htaccess I would guess...

    My .htaccess:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Anything wrong?

  6. esmi
    Forum Moderator
    Posted 1 year ago #

    No - that's fine. Check with your hosts that mod_rewrite is running on your server.

  7. totallytech
    Member
    Posted 1 year ago #

    I run my own server, I've checked it and mod_rewrite is enabled :(

    How odd :(

  8. esmi
    Forum Moderator
    Posted 1 year ago #

    Is there anything else in your .htaccess file? Can you re-start the server?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.