WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks problem (17 posts)

  1. Matys1001
    Member
    Posted 1 year ago #

    Hello !

    I'm having a strange problem with permalinks ;) when i use %postname% or %post_id% as a structure of my permalinks on the main page of my store the "next page" displays nothing found.

    But when i go into any category it works fine, only the main page doesnt work.
    However, If i use the defoult permalinks such as "http://raskon.pl/?p=123"
    The whole website is working fine ;)

    Ive been trying to change a little of httcaccess file but i dont know how ;) First time doing this. My .httc looks that

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Could you help me ;) ? Oh and the website is http://www.raskon.pl/sklep

  2. edpittol
    Member
    Posted 1 year ago #

    Are you have the module rewrite actived?

  3. Matys1001
    Member
    Posted 1 year ago #

    What do you exactly mean xD How can i check that and if not activate xD ?

    But look when you go into this category for example
    http://raskon.pl/sklep/odziez-robocza-i-ochronna/

    you can feel free and chang pages as you wish xD so i think it works good , but just not for the main products page xD

  4. edpittol
    Member
    Posted 1 year ago #

    The website redirect http://raskon.pl/sklep/page/2 to http://raskon.pl/sklep/2. Try install this plugin:

    http://wordpress.org/extend/plugins/monkeyman-rewrite-analyzer/

    Test this url sklep/page/2 and see the result.

  5. Matys1001
    Member
    Posted 1 year ago #

    hm i dont know exactly what does it mean so im giving you print screen xD

    http://imageshack.us/photo/my-images/266/monkeya.jpg/

    Could you check that xD and tell me what to do ?

  6. edpittol
    Member
    Posted 1 year ago #

    Its something wrong, he must put 2 in page. Maybe did you create a page with the name sklep?

  7. Matys1001
    Member
    Posted 1 year ago #

    Hm, i created the page that name is sklep, thats why its named like that ;)

    But it doesnt change anything,
    first time when i installed the theme it was named products-page and it was also didnt work like now ;)

  8. edpittol
    Member
    Posted 1 year ago #

    I was without a WordPress installation. Now I tested the rewrite rules with the plugin. It should take this rule:

    (.?.+?)/page/?([0-9]{1,})/?$

    And it take this:

    (.?.+?)(/[0-9]+)?/?$

    I don't know why. Maybe some code 'delete' the rule.

  9. Matys1001
    Member
    Posted 1 year ago #

    Wow ! thanks, but could you pls tell me where should i change that xD ?
    IN htcaccess or where becouse i dont see anything like that in that file ;)

  10. edpittol
    Member
    Posted 1 year ago #

    I don't must change the htaccess. The wordress manage the rewrite rules internally. Read it:

    http://codex.wordpress.org/Rewrite_API

    You must looking for where has a changing of the default rules. Probally this is the problem.

  11. Matys1001
    Member
    Posted 1 year ago #

    Hey my rerite.php looks like that, could check that xD ?

    [1934 lines of core code moderated]

  12. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    This is not a core WordPress issue.

  13. edpittol
    Member
    Posted 1 year ago #

    I agree. In some additional (theme or plucan) code, maybe the rules was altered.

  14. Matys1001
    Member
    Posted 1 year ago #

    :) then how am i supposed to find that xD ?
    where should i search ? This theme is Mazine and its using wp-ecomerce plugin as a shop ;)

  15. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  16. Matys1001
    Member
    Posted 1 year ago #

    Hm i dont have any plugins installed in there only wp-ecommerce so if i disable this the whole store wont work xD

    I got the same problem on other site and its after i install the theme so its something inside the theme or wp-ecommerce i guess ;)
    Not the plugins i guess ;)

  17. Matys1001
    Member
    Posted 1 year ago #

    Hmmm the whole thing is in the redirect ;) when i hover on page 2 it displays raskon.pl/sklep/page/2 after clik its raskon.pl/sklep/2 xD the 'page' disappeard ;) have any idea how to hange that xD ?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.