WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalinks problem (17 posts)

  1. brucenow
    Member
    Posted 3 years ago #

    I had wordpress with a buddypress twenty ten child theme and a buddypress plugin all working great yesterday. Then I read where you have to install wordpress in the root directory to have a multisite network so I moved my wordpress out of its folder into the root directory on GoDaddy. The permalinks would'nt work for Buddypress in the default setting, but they wouldn't work at all in any other setting.

    Deleted everything and reinstalled. Same problem. what to do?

  2. Did you change the two URLs at Settings/General before moving the files?

    http://codex.wordpress.org/Moving_WordPress

  3. brucenow
    Member
    Posted 3 years ago #

    It's a mute question, since I deleted wordpress and reinstalled it. But for the record, I think GoDaddy support had me change the urls after we made the move and discovered the problem.

  4. So, are you still having the problem? If so, can you access the Dashboard?

  5. brucenow
    Member
    Posted 3 years ago #

    Oh yes, I can access the dashboard, but I can't go to the About page via the horizontal menu below the header unless the permalinks are set to default.

  6. Are you on a Windows or Linux server?

  7. brucenow
    Member
    Posted 3 years ago #

    I believe GoDaddy is a linux server.

  8. You could be on either a Linux or Windows server with GoDaddy. Contact them to find out what you're on and ask if mod_rewrite is active on your server.

  9. brucenow
    Member
    Posted 3 years ago #

    Yes, just checked. It's Linux.

  10. And is mod_rewrite active on the server?

  11. brucenow
    Member
    Posted 3 years ago #

    Yes, mod_rewrite is active on all their servers by default.

  12. Sometimes GoDaddy takes a while for permalinks to sync up (.htaccess is cached, IIRC). Give it an hour without fiddling, see how it goes?

  13. brucenow
    Member
    Posted 3 years ago #

    It's been over an hour since I touched it. No change. Something new I discovered - when I do change the permalink setting to day and name, then edit the About page and hit the view page button, in the address window of my browser is the path that give the name of the page, but no day.

  14. Were you trying just postname before?

  15. brucenow
    Member
    Posted 3 years ago #

    No, just clicking on the first option below default: Day and Name.

  16. brucenow
    Member
    Posted 3 years ago #

    Although I think I did try the "numeric" option once, and then went back to alternating between "default" and "Day and Name" options.

  17. brucenow
    Member
    Posted 3 years ago #

    I switched my hosting to HostMonster. Problem resolved.

Topic Closed

This topic has been closed to new replies.

About this Topic