WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks, preg_match '!' delimiter, and Photopress (4 posts)

  1. welsberr
    Member
    Posted 6 years ago #

    My weblog this morning suddenly changed how it displayed pages. Eight lines of PHP errors show up at the top:

    Warning: preg_match() [function.preg-match]: No ending delimiter '!' found in /usr/local/www/vhosts/austringer/public_html/wp/wp-includes/classes.php on line 95

    Warning: preg_match() [function.preg-match]: No ending delimiter '!' found in /usr/local/www/vhosts/austringer/public_html/wp/wp-includes/classes.php on line 96

    Warning: preg_match() [function.preg-match]: No ending delimiter '!' found in /usr/local/www/vhosts/austringer/public_html/wp/wp-includes/classes.php on line 95

    Warning: preg_match() [function.preg-match]: No ending delimiter '!' found in /usr/local/www/vhosts/austringer/public_html/wp/wp-includes/classes.php on line 96

    Warning: preg_match() [function.preg-match]: No ending delimiter '!' found in /usr/local/www/vhosts/austringer/public_html/wp/wp-includes/classes.php on line 95

    Warning: preg_match() [function.preg-match]: No ending delimiter '!' found in /usr/local/www/vhosts/austringer/public_html/wp/wp-includes/classes.php on line 96

    Warning: preg_match() [function.preg-match]: No ending delimiter '!' found in /usr/local/www/vhosts/austringer/public_html/wp/wp-includes/classes.php on line 95

    Warning: preg_match() [function.preg-match]: No ending delimiter '!' found in /usr/local/www/vhosts/austringer/public_html/wp/wp-includes/classes.php on line 96

    I have been using the Photopress plugin to display photos. Suddenly it is not serving up any photos, nor is the sidebar link to Photopress displayed.

    If I change my permalink structure from date and name to default, the PHP error lines are not displayed, but Photopress is still missing.

    Another WP install on the same server is still showing Photopress-entered pictures with no problem.

    Google doesn't turn up a fix, but I found at least one other WordPress blog that is having the same difficulty.

  2. welsberr
    Member
    Posted 6 years ago #

    More information: Apparently, the PHP on the server was upgraded yesterday. Why I didn't see a change in pages until today, I'm not sure.

    New version is: PHP Version 5.2.3

    './configure' '--enable-versioning' '--with-layout=GNU' '--with-config-file-scan-dir=/usr/local/etc/php' '--disable-all' '--enable-libxml' '--with-libxml-dir=/usr/local' '--enable-reflection' '--program-prefix=' '--enable-force-cgi-redirect' '--enable-discard-path' '--enable-fastcgi' '--with-regex=php' '--with-zend-vm=CALL' '--enable-zend-multibyte' '--prefix=/usr/local' '--mandir=/usr/local/man' '--infodir=/usr/local/info/'

  3. jazbek
    Member
    Posted 6 years ago #

    hi welsberr,

    did you ever get this resolved? i am having the same problem. i also use photopress.

    tia.

  4. simplyelena
    Member
    Posted 6 years ago #

    I’ve got the same problem. This how I’ve solved it:

    1)Disabled Photopress and updated permalinks. The warning has gone.
    2)Downloaded and installed new version of the Photopress (1.0.2) – no warnings.

    P.S. I use WordPress 2.3.2

Topic Closed

This topic has been closed to new replies.

About this Topic