WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks post-name option adds index.php to path and don't work (2 posts)

  1. radweb
    Member
    Posted 1 year ago #

    Here is my problem. My links work fine if I use the default setting. However, when I use Post Name setting, it gives me this:
    http://www.buildinglinks.ca/wordpress/index.php/sample-post/

    What I'm looking for is:
    http://www.buildinglinks.ca/wordpress/sample-post/

    Of course, later, when the site goes live, the link will have to be
    http://www.buildinglinks.ca/sample-post/

    I need the post-name settings so I can optimize them for SEO.

    I am using the Inovado theme purchased from themeforest.net. I don't know if that has anything to do with it. I've never had this problem before.

    I need to be able to edit the URLs of the new site so that once the site is up and running, the URL's are the same as some of the URL's in the old site - they were doing well in Google and we want to keep that position.

    Just to restate - if I use the post-name option, the links do not work at all.
    thanks for your help.
    Radiance

  2. jodzeee
    Member
    Posted 1 year ago #

    Are you using a Windows server instead of Apache?
    http://codex.wordpress.org/User:ringmaster/IIS#Alternate_Rewrite_Methods

Topic Closed

This topic has been closed to new replies.

About this Topic