WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalinks, Permissions and htaccess (4 posts)

  1. streetsweeper
    Member
    Posted 6 years ago #

    Hi

    I'm having a problem with my page id's.

    I have a test website at http://www.streetsweeper.net.au

    I am using "Flickr Photo Album"

    In order to use the plugin. I need the Permalinks set to "something other than default"

    When I do this, no matter which option I choose - let's say 'numeric' - none of the links to my post work anymore. Pages that I have created work, but only as the default url style.

    I think this has something to do with my htaccess file, but I can't modify the permissions in Fetch.

    If I delete the file, the plugin creates it again.

    What's going on?

    ta.toby

  2. dopecoder
    Member
    Posted 6 years ago #

    Hi streetsweeper, when you update your permalink settings you have to add some code to your htaccess file that is given at the bottom of the permalinks page whenever you change the permalink settings. Did you do this? Also what is fetch, is it an ftp program? i use FileZilla and i can change permissions with out any problems.
    Have a read of this article How to create SEO titles using Permalinks

  3. streetsweeper
    Member
    Posted 6 years ago #

    Hi

    Yes - Fetch is an ftp programme. I have managed to change the permissions for "htaccess", but still no joy. I also tried manually updating the "htaccess" file each time I change permalink - but I still get the 404's.

    From my research, I think that my ISP needs to change the mod_rewrite and 'allow access' setting on the server side...?

    I'm pretty sure I've tried every other option - except for a total reinstallation and rewrite!

    thanks

  4. streetsweeper
    Member
    Posted 6 years ago #

    I have resolved this issue.

    It was the mod_rewrite access on my ISP's side. They have contacted me today and switched the mod_rewrite on.

    thankyou all

Topic Closed

This topic has been closed to new replies.

About this Topic