WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks only work as ?page-id=# (3 posts)

  1. huntedthomas
    Member
    Posted 11 months ago #

    I have been having a recurring problem with a wordpress site someone else made and I help maintain for a client. The permalinks refer to the page id only (.com/page-id=123). When I change them in settings/permalinks to show post-name. It references a problem with the htaccess not being writable.

    When I change the code in the htaccess to make it writeable, the links change to how i want them (.com/mypage) but it returns a 500 error and says the page doesn't exist.

    I have been reading other forum posts but cannot seem to get my site to work with the simple permalink form. Any help is appreciated.

    Thank you.

  2. Justin
    Member
    Posted 11 months ago #

    Have you simply tried to make the htaccess file writable and then try to set the permalinks through WordPress again?

    Some hosts for some reason do not have htaccess enabled which could cause this error as well.

  3. Justin
    Member
    Posted 11 months ago #

    Sorry I meant to say "Make sure you host has mod_rewrite enabled"

Reply

You must log in to post.

About this Topic