WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks: only default works (5 posts)

  1. on_edge
    Member
    Posted 5 years ago #

    Only default permalink settings will work. Other settings return Apache Not Found page when navigating to any page other than home page. Initial installation (WP 2.8/Thesis 1.5.1) for this site. But the site is one of 3 on the same hosting account. I tried deactivating all plugins and resetting to default WP theme. No luck.

  2. Samuel B
    moderator
    Posted 5 years ago #

    if the server has mod_rewrite turned on it should work
    try adding this to top of your .htaccess

    Option +FollowSymlinks

  3. on_edge
    Member
    Posted 5 years ago #

    Thanks for the suggestion. Both problems persist. Server does, indeed, have mod_rewrite.

  4. on_edge
    Member
    Posted 5 years ago #

    Found the answer. It was a matter of changing my httpd.conf file. Had to change:

    AllowOverride None to AllowOverride All

  5. xslord
    Member
    Posted 5 years ago #

    Well i have something similar but it's in reverse:

    When i set the permalinks to one of the available option it works!
    but when i reverse to DEFAULT i get the following (when loading a page):

    "The requested URL /wordpress/about was not found on this server."

    Has anyone got an idea why?

    BTW: when i revert to DEFAULT for permalinks my .htaccess looks like this:

    # BEGIN WordPress

    # END WordPress

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags