WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks on WordPress 2.7 (21 posts)

  1. StoraX
    Member
    Posted 5 years ago #

    I upgrade wordpress 2.7 my wp site ... But not working now permalinks ... I try another permalinks "Day and name" - "Numeric" oder "Custom Structure" , but not working .. When i was 2.6 , my permalinks are working perfectly ...

    What is the problem ?

  2. darrinb
    Member
    Posted 5 years ago #

    Check your .htaccess file. Make sure it's writable by WP and check to see if it has something similar to this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Also check this section of the Codex for further information:
    http://codex.wordpress.org/Using_Permalinks

  3. StoraX
    Member
    Posted 5 years ago #

    I check it , its writable by wp and

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    But not working . When i will enter a post , not open . Only open my home page . And tittle : " Nothing found for ..... "

  4. darrinb
    Member
    Posted 5 years ago #

    Something similar happened to another user last night:
    http://wordpress.org/support/topic/226691?replies=10

    Check your permalink settings in your Admin panel (Settings > Permalinks > Common Settings) , what are they set on? Change them to default, then go to your blog, and refresh your browser and see if your post links work.

  5. StoraX
    Member
    Posted 5 years ago #

    Yeap , i check it and now default mode , it works on default mode . Before i used : " /%postname%.html " ... When i try this , not work . Oder another permalinks ... Only default mode is working . I deleted .htaccess file and re-make it . But not working . I don't understand ...

  6. darrinb
    Member
    Posted 5 years ago #

    Some hosting companies do not recognize new .htaccess file immediately. It takes an hour for my company to recognize a new .htaccess file.

    Is WP installed in a sub-directory of your site or is it in the root directory? A user last night has a similar problem to yours and it ended up being his .htaccess was in the wrong directory.

    I'd try this:

    1. Reset your your permalinks to default.
    2. Create a blank .htaccess file and upload to the appropriate directory.
    3. Go back to your permalinks settings and choose whatever "pretty" version you want. WP *should* auto-update your .htaccess file.
    4. Check your .htaccess file and see if WP did, in fact update it.
    5. Go to your blog, refresh (do a full refresh) your browser and check your links.

    Like I mentioned, your host company may not recognize your .htaccess file immediately. Check with your company.

  7. StoraX
    Member
    Posted 5 years ago #

    I have a VPS . And only 1 site on it . .htaccess file is on root directory .

    Before : i use the wordpress 2.6 . And my sites permalinks were worked . After , i update 2.7 and not working my permalinks . I don't change any settings . Only upload new files to server .

  8. StoraX
    Member
    Posted 5 years ago #

    Any idea ?

  9. darrinb
    Member
    Posted 5 years ago #

    On my site, my wordpress installation is in /blog/, not the root, so my .htaccess file looks similar to this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>
    # END WordPress

    Where is yours installed?

  10. Frostyfrog
    Member
    Posted 5 years ago #

    I have a fresh install on my server and the only one that works is the default one. All of the others return a 404 not found page.

  11. StoraX
    Member
    Posted 5 years ago #

    My wordpress intallation is in root directory , i don't change my directory . I said : " only upload wp 2.7 to my vps , and update databases " ... After starting don't working ... i don't understant .

    I remove every files , and i re-upload wordpress 2.7 . But not working this way . what can i do ?

    Yesterday , i change my web service to lighttpd from apache . But not opened my site on lighttpd ...

  12. StoraX
    Member
    Posted 5 years ago #

    Any idea ?

  13. MadsK
    Member
    Posted 5 years ago #

    I accidently deleted my old .htaccess file and went through the same thing.

    What i did was:

    Create a new .htaccess file and made one line in it:

    RewriteEngine On

    Upload it to your root and change the CHMOD to 777 - Wait 1-2 mins.

    After that go back to admin and change the permalinks to whatever you want. Wait again for about 1-2 mins. And then reload your page (ctrl+F5 preferred)

    It worked for me!

  14. strangelyperfect
    Member
    Posted 5 years ago #

    I had a similar problem after the 2.7 upgrade...
    It started with one post not showing properly when viewed singly and then went to two and then today it went bonkers and nothing showed as individual posts! They showed on the default front page list though.
    So after fishing around the web I eventually ended up here and tried a complete roll-back and part-re-install.

    I took out all the plugins that had anything to do with permalinks and caching:
    Broken Link Checker
    Deans Permalink Migration
    Easy Redirect
    Enforce www. Preference
    Google XML Sitemaps
    Permalink Redirect
    WP Supercache

    I've been mixing and matching with these things over the various incarnations of WordPress, mind you, so they weren't all on when I finally pulled the plug, so to speak.

    I then flipped Permalinks back to defaults and the menu structure and posts' links worked correctly.
    On going back to pretty permalinks I still had no joy...

    I then re-uploaded good copies of all files in the root and wp-admin folders (I didn't do wp-includes), overwriting everything.

    But still no joy... (BTW, in all these tests, I used Firefox and Opera, refreshing each time).

    So I followed @Madsk's words above and whipped out the old htaccess by renaming and made a new htaccess and just added the single line suggested, set as 777.
    NOW the pretty permalinks started to work and WordPress wrote it's stuff to htaccess.

    Now it's really curious... I copied the "new" WP generated code to the old htaccess file, overwriting the WP code at the bottom, where it was anyway... IT WAS EXACTLY THE SAME!! Then I swapped the files over (by renaming using my Hosting client) keeping exactly the same previous permissions of 644.

    And STILL everythings works! Why? I don't know, but I'm happy!

    My next task is to re-enable super cache and google sitmaps and then gingerly try some other plugins. Redirecting I can probably live without now as the number of posts on the current permalink structure massively outnumbers those on the old default system I previously used.

  15. paul
    Member
    Posted 5 years ago #

    Not having the same success. I set up a testbed on a different system and have found the same problem in 2.6.1. I plan to work back until I find a version that works and see if it's possible to figure out what it is.

    You'd think this would be something that would have shown up in the release process.

  16. balbert
    Member
    Posted 5 years ago #

    Paul & FrostyFrog -
    i was having the same issue were resting the .htaccess file still didn't work. Then looked at the codex page on pretty urls and there is a small section on requirements. The one that caught my eye was "FileInfo directives allowed (e.g. AllowOverride FileInfo, AllowOverride All)". Then I remembered i needed to set this up on my other blog on my old server when it was first created.

    My new blog, were pretty urls aren't working, is on a new Mac OS X Server install. I went in to my Apache config file for the site in /etc/httpd/sites. There, i saw that AllowOverride was set to "none". updated that to "All", restarted Apache and all was good.

    If this is a new server install, you might need to check your Apache config file for the correct settings. See http://codex.wordpress.org/Using_Permalinks and the "Using "Pretty" permalinks" section were it lists the requirements. Not only do you need mod_rewrite on and .htaccess with the right permissions, there are other web server settings.

  17. paul
    Member
    Posted 5 years ago #

    balbert, i have been over all that. I wonder if the fact the Codex points to the Apache 1.3 manual and I have been using 2.x (2.2 now) for years has anything to do with it? I have AllowOverride All set on both sites I have been testing: no joy.

  18. row_01
    Member
    Posted 5 years ago #

    I'm having the same problem. After hours and hours of research on this, I'm convinced it's a WordPress bug with this new version. Am urgently awaiting version 2.7.1 to fix this bug.

  19. jbarse
    Member
    Posted 5 years ago #

    I think there's a relatively straight-forward answer to this, at least on Leopard server.

    First, as noted above make sure there's a .htaccess file in the root directory of the site and that WP can write it. You'll know it's writeable when you make the permalink structure change in WP and it confirms that the structure's changed.

    Second, in Mac Server Admin, go to the 'Options' tab for the particular site you're working on and make sure 'Allow All Overrides' is checked.

    That's all it took for me (Leopard server 10.5.6), although it did take a little digging and reading. HTH.

  20. garyion
    Member
    Posted 5 years ago #

    Thanks MadsK, your solution worked for me - do I reset the chmod from 777 afterwards?

  21. b4ng83
    Member
    Posted 5 years ago #

    On my wp installation (2.7.1) I have this problem where my url changes (http://www.becomeknown.co.uk) but the page doesn't. I've tried various plugins and changed the permalinks using the standard WP option but it still happens. I currently have custom URLs turned off and it's set to default URLs due to this problem.

    The only plugins I have installed are "All in One SEO", "Contact Form 7", "Scaleable Contact Form", "Twitter for WordPress" and "WP-Mail-SMTP". Has anyone come across this problem before? Know what might be causing it?

Topic Closed

This topic has been closed to new replies.

About this Topic