WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks on IIS 7.5 (3 posts)

  1. johnjust
    Member
    Posted 2 years ago #

    I'm trying to define the Permalinks for an old WordPress blog on IIS 7.5, but the rules in my web.config don't seem to work properly. No matter where I looked online, I only found one chunk of code (which was weird, since it should technically be a little different, depending on how you have the permalinks configured):

    <rewrite>
    <rules>
    <rule name="Main Rule" stopProcessing="true">
    <match url=".*" />
    <conditions logicalGrouping="MatchAll">
    <add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
    <add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" />
    </conditions>
    <action type="Rewrite" url="index.php/{R:0}" />
    </rule>
    </rules>
    </rewrite>

    My permalinks are defined using the custom structure:

    /%category%/%postname%/

    How do I turn this into a valid rewrite rule? My experience with IIS is almost non-existent, so any help is appreciated.

    Thanks.

  2. craighillyard
    Member
    Posted 1 year ago #

    i'm having this exact same problem.

  3. zappmania
    Member
    Posted 1 year ago #

    I was able to get it working on my site. my site is on IIS (Windows hosting).
    try below link may this steps helps you too...

    http://www.zappmania.in/index.php/2013/03/27/getting-wordpress-pretty-permalinks-working-on-iis-windows-hosting/

Topic Closed

This topic has been closed to new replies.

About this Topic