WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks OK but WP loads archive list instead of single post (9 posts)

  1. Stephanie Leary
    Member
    Posted 8 years ago #

    Permalinks seem to be working fine (whew! had nuthin' but trouble in 1.5) but all is not well. When I load up an archive page (http://www.sillybean.net/archives/704 for example), I get the archive list instead of the individual post. In my theme, archives.php contains the list code and single.php is present and accounted for. All files' permissions set to 755. The archives were working in 1.5. What am I missing?

  2. vkaryl
    Member
    Posted 8 years ago #

    Which theme is that? Do you have an archive.php as well as archives.php?

  3. Stephanie Leary
    Member
    Posted 8 years ago #

    I built this; it isn't a standard theme. There is an archive.php, containing more or less what's in the default theme's archive.php, but it doesn't seem to come into play -- I deleted it and saw no difference.

  4. vkaryl
    Member
    Posted 8 years ago #

    Well, that was my only thought.... I've not seen this even in 1.5+....

  5. Stephanie Leary
    Member
    Posted 8 years ago #

    Messed with this some more tonight... any other permalink structure works fine, but numeric still loads the archive list whether I'm using one of my themes or the default.

  6. mylagoon
    Member
    Posted 8 years ago #

    I had the same problem in WP2.0RC1. The problem only occured however when i added a directory slug for categories that was the same as the first part of the slug for posts.

    Eg.
    for posts
    /products/category/subcategory/post name
    for categories
    /products/category name

    Once I removed the custom category edit, all worked fine again. Weird eh? Perhaps this is what you are experiencing too? Not sure if the same problem occurs in WP1.5.2 or below, haven't tested it.

  7. Stephanie Leary
    Member
    Posted 8 years ago #

    You're talking about the category base? Mine's blank.

  8. moshu
    Member
    Posted 8 years ago #

    Try changing the page-slug for your "archives" Page.

  9. Stephanie Leary
    Member
    Posted 8 years ago #

    Brilliant. Thanks, moshu.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.