WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalinks Not Working with Rewrite Script on Zeus (16 posts)

  1. thestealthyfox
    Member
    Posted 1 year ago #

    I'm building a Wordress site using Namesco hosting and have followed all of the instructions to create and add a rewrite script, but I'm still getting a 404 screen when I remove index.php from the permalink.

    I've contacted Namesco support and surprise surprise heard nothing back (I've read that they are not bothered by such queries).

    Can anyone suggest anything else please I'm losing the will to design!

    Thanks...

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    have followed all of the instructions to create and add a rewrite script

    What instructions?

  3. thestealthyfox
    Member
    Posted 1 year ago #

    Sorry esmi - there are various blog posts explaining how to create the rewrite script - http://www.benhuson.co.uk/2010/03/01/wordpress-permalinks-zeus-server/

    I followed this one.

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    Your best bet would be to speak to your hosts about this. They may have some documentation that you can refer to. Unfortunately Zeus servers are always a P*TA to deal with. :-)

  5. thestealthyfox
    Member
    Posted 1 year ago #

    I know. Namesco support are useless and haven't even got back to me yet.
    It's so frustrating! I'm considering moving my client's hosting now... will probably be easier!

    Thanks anyway...

  6. esmi
    Forum Moderator
    Posted 1 year ago #

    Just about any *nix hosting that doesn't use Zeus would make your life a lot easier all round. I avoid them like the plague.

  7. blueklein76
    Member
    Posted 1 year ago #

    I'm having the exact same problem. The final comment here suggests that Namesco requires us to keep the index.php part:
    http://wordpress.org/support/topic/permalinks-does-not-work-1
    But that's not acceptable for me.

    If you hear something useful back from Namesco support please post it, but I'm now looking for a new hosting provider.

  8. thestealthyfox
    Member
    Posted 1 year ago #

    Well I've now emailed Namesco suggesting I'm going to move my hosting, so we'll see if that escalates a response! Will keep you posted...

  9. thestealthyfox
    Member
    Posted 1 year ago #

    So, this is their response. Interesting when I've already said I've added the rewrite script as they suggested. USELESS!

    Dear Hayley,

    Thank you for getting in touch with us about WordPress,

    For more information on WordPress rewrite scripts please see: http://www.names.co.uk/support/hosting/new/linux_hosting/1119-wordpress_rewrite_script.html

    Please let us know if you have any further questions - we will be more than happy to help.

    You can also view a number of useful articles and video tutorials in our Knowledge Base at http://www.names.co.uk/knowledge

    Please rate our responses so that we may improve our service. Visit http://feedback.namescosupport.co.uk/index.php?id=553 to let us know how we've done

  10. thestealthyfox
    Member
    Posted 1 year ago #

    Well Namesco never came back, however I've got it to work!
    I was creating the rewrite script in notepad then changing to a script file in the ftp which didn't work. I have however just created it in text wrangler and saved it straight away as rewrite.script.

    Used the coding on this site: http://www.niallflynn.com/seo-news/register-365-wordpress-permalinks/

    So relieved and can safely say, Namesco have the worst customer service I have ever experienced (ie non existent!)

    Hope it works for you blueklein76!

  11. esmi
    Forum Moderator
    Posted 1 year ago #

    That sounds like the file format of the saved file was incorrect when you used NotePad. You almost certainly need to save the file in Unix - as opposed to PC - format.

  12. thestealthyfox
    Member
    Posted 1 year ago #

    I know - to be honest I'm learning as I go along! :)

    Thanks Esmi.

  13. esmi
    Forum Moderator
    Posted 1 year ago #

    I use TextPad on Win7 for all file creation/editing and always save server files in Unix format rather than the default PC format. Might be worth playing with if you use Windows a fair bit.

  14. blueklein76
    Member
    Posted 1 year ago #

    Well a big thank you to thestealthyfox for pursuading me to go back and try this again. I also now have permalinks working (without the index.php!) using the above script from Niall Flynn.

    It still wasn't easy though. I'm on a Mac so (in theory) my line endings are Unix by default, but I forced the line endings to Unix anyway.

    After uploading as rewrite.script, I tried a permalink, and - 404 page not found. Tried re-saving the permalink settings, refresh, 404 page not found. Tried re-applying my theme, refresh, 404 page not found. Cleared the browser cache, refresh, 404 page not found.

    Finally in desperation I tried a different permalink - and it worked! Hmm. So I went back to the previous permalink and added a short query string on the end along the lines of "?nocache=1" - and then it too sprang into life.

    So I can only guess that Namesco might be using a caching layer that includes the caching of 404 errors. Then if you've already tried your permalinks out before adding the rewrite.script it carries on (for a while at least) serving up the old errors. My page edits are showing up fine though so who knows.

    Anyway, thanks again!

  15. macgiver
    Member
    Posted 10 months ago #

    Hi Guys,

    I'm really sorry because I re-opened this discussion.

    My client (a charity foundation) use namesco and zeus.

    I follow the solution provided by thestealthyfox

    "I was creating the rewrite script in notepad then changing to a script file in the ftp which didn't work. I have however just created it in text wrangler and saved it straight away as rewrite.script.

    Used the coding on this site: http://www.niallflynn.com/seo-news/register-365-wordpress-permalinks/ "

    But the website is still down (with page).

    I tried to delete rewrite.script and re-upload but nothing happened.

    I need some help in order to fix this problem.

    blueklein76 Could you explain step by step how to fix the problem with permalinks?

    I read this: "Finally in desperation I tried a different permalink - and it worked! Hmm. So I went back to the previous permalink and added a short query string on the end along the lines of "?nocache=1" - and then it too sprang into life."

    but I didn't understand, sorry.

    Many thanks in advance for help

  16. blueklein76
    Member
    Posted 10 months ago #

    Hello macgiver,

    I used the rewrite.script from the niallflynn site without any changes. If you're using a text editor, make sure the line endings are set to unix. If you're uploading the script with FTP then make sure you are in binary mode (not ascii). It needs to go into the web site's root directory - in the same place as index.php.

    After that it just worked for me, but only after a while. Errors were still returned for pages that I'd already tried to visit, so test it out on some different pages. After some time all the pages were then ok.

Topic Closed

This topic has been closed to new replies.

About this Topic