WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks not working on WP 2.6 with Yahoo Hosting (8 posts)

  1. jodimfs
    Member
    Posted 5 years ago #

    I'm running WordPress 2.6 with Yahoo hosting. I recently noticed that my permalinks aren't working. Although I don't have index.php built into my permalink structure, it appears that my website is trying to add it. I tried the workaround of adding /category and /tag but it's still not working. Any advice?

    The site is http://www.momsfavoritestuff.com

  2. moshu
    Member
    Posted 5 years ago #

    Try to find Y! related solutions:
    http://wordpress.org/search/yahoo+permalink?forums=1

  3. jodimfs
    Member
    Posted 5 years ago #

    Thanks. I basically had to change my blog address to end in index.php, then I had to install the Permalink redirect plug in so that all of my old URLs point to the new ones.

  4. wedge1082
    Member
    Posted 5 years ago #

    jodimfs

    I am in the same boat you were in. I tried all the same steps that you did and my links still did not work.

    What exactly did you enter into the permalink redirect plugin?

  5. Novachord
    Member
    Posted 5 years ago #

    I recently manually reinstalled WordPress 2.6 (on Yahoo hosting) and started experimenting with Permalinks. I can't get anything other than the ugly default setting to work. I've tried putting index.php/ in front of whatever I try, but nothing works. I also tried installing the redirect plugin mentioned here but before I could check the settings it basically created an infinite loop on my site, rendering it inaccessible. Any other ideas?

  6. Novachord
    Member
    Posted 5 years ago #

    Nevermind, had to use the plug-in that disables canonical redirects mentioned here:

    http://wordpress.org/support/topic/135725

    Seems to be working correctly now

  7. jodimfs
    Member
    Posted 5 years ago #

    First, I went into my settings, and for the Blog address (NOT the WordPress address) I added index.php to the end. At that point, my permalinks worked, but the old ones all had to be redirected.

    I installed the redirect plugin, and then input the new permalink structure in the second box (titled Path pairs to redirect from and to)
    and put my old structure (without the index.php in the address) in the third box (titled Old Permalink Structure).

    I couldn't figure out how to get it to work without the index.php.

  8. williams94086
    Member
    Posted 5 years ago #

    jodimfs: It looks like you've been successful in establishing redirects from existing posts to new urls using index.php in them. I am also using Yahoo as a host (such a pain) for WP 2.6.

    Which redirect plugin are you using? I've tried 'Redirection' but it doesn't redirect to pages using index.php. Any info on exactly what you put in the from and to woulds be also be helpful. I've tried using an exact url as well as regular expressions and nothing seems to work.

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic