WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks not working - getting 404 page (3 posts)

  1. michalgrinvald
    Member
    Posted 5 years ago #

    I am trying to set my permalinks to custom : /%postname%/
    When I look at posts, the link on top seems good. But when I try to use the link in another browser I get 404 page not found.
    The default works fine. I have tryed to create an .htaccess file but it didn't help.
    Can someone advice?
    Thanks
    Michal

  2. tgiokdi
    Member
    Posted 5 years ago #

    I'm not clear on what the situation is. do you have to url to showcase your problem?

  3. Shane G
    Member
    Posted 5 years ago #

    Hi,

    Change the permalinks settings to your desired one and add this code in htaccess file of your domain:

    # BEGIN WordPress

    <IfModule mod_rewrite.c>
    ErrorDocument 404 /index.php?error=404
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Thanks,

    Shane G.

Topic Closed

This topic has been closed to new replies.

About this Topic