WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks not working (3 posts)

  1. steve_linn
    Member
    Posted 6 months ago #

    I am having issues getting permalinks to work on my localhost

    I am running Mac OSx with standard php / apache install

    When I activate my permalinks to post name I get this error message

    403 Forbidden

    Forbidden

    You don't have permission to access /~steve02/allisongrayce/index.php on this server.

    Here is what I have done so far
    ---------------------------------------------------
    htaccess file --permissions set to 777

    Options -Indexes
    Options +FollowSymLinks

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /~steve%202/allisongrayce/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /~steve%202/allisongrayce/index.php [L]
    </IfModule>

    # END WordPress

    -----------------------------------------
    etc/apache2/httpd.conf

    has the following code in it

    # User home directories
    Include /private/etc/apache2/extra/httpd-userdir.conf

    -----------------------------------------
    httpd-userdir.conf has the following code in it

    # Settings for user home directories
    #
    # Required module: mod_userdir

    #
    # UserDir: The name of the directory that is appended onto a user's home
    # directory if a ~user request is received. Note that you must also set
    # the default access control for these directories, as in the example below.
    #
    UserDir Sites

    #
    # Users might not be in /Users/*/Sites, so use user-specific config files.
    #
    Include /private/etc/apache2/users/*.conf
    <IfModule bonjour_module>
    RegisterUserSite customized-users
    </IfModule>

    --------------------------------------------

    steve 2.conf file has this code in it

    <Directory "/Users/steve 2/Sites/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride All AuthConfig

    Allow from all
    </Directory>
    --------------------------------------------

    Any suggestions?

  2. steve_linn
    Member
    Posted 6 months ago #

    I figured this out

    All I had to do was add /index.php/%postname%/ to the custom structure

    I'm not exactly sure why this is…but it solved the problem

    can someone explain why this works?

  3. Jesin A
    Member
    Posted 6 months ago #

    I guess the problem is caused due to the space in the directory name "steve 2". Rename it to steve_2 and also find & replace all occurrences of it in the httpd.conf file.

Reply

You must log in to post.

About this Topic