WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks not working (2 posts)

  1. arjunbajaj
    Member
    Posted 4 years ago #

    Hey everyone,

    I have hosted wordpress on my site.....
    I have PHP 5 and MySQL5 on my hosting.....(I dont know which version am i using for WordPress)

    The default config for permalinks still works....

    but when i change.....

    IT DOESN'T......
    and i cant even access my home page.....

    when i try to access my site : http://arjunbajaj.com it doesn't load and shows me error 404, page not found...

    but when i type http://arjunbajaj.com/index.php it loads.........

    and there's also another problem.......
    when i change to the already available permalinks in my wordpress 2.9.2, some of the posts and pages load as single pages.......

    but when i put my own permalinks the posts and pages even don't load....

    i guess it is some .htaccess problem......

    but i really don't know what it is and actually i'm not a wordpress master so i really dont know anything except using the UI some FTP and some code but not much of html and php......cause rite now i'm learning java.....

    i have to change my permalinks to only the names i specify, like arjunbajaj.com/<post name which i can change>

    what should i do???

    and i really need to get that to work fast or my site will be in a mess cause i have to work with post urls......

    please help......

    thnx.....

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Try resetting your custom permalinks back to the default setting. If that works, then try reading Using_Permalinks before setting a custom permalink structure back up again.

Topic Closed

This topic has been closed to new replies.