WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Permalinks not working (10 posts)

  1. pachrang
    Member
    Posted 4 years ago #

    Hi,

    Permalinks for my blog is not working

    my .htaccess file is
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    i want to change the permalink to
    /%year%/%monthnum%/%postname%/

    but my blog's post are not working and coming out with page cannot be displayed error

    if i change to default permalink, everything works fine...

    if i update the permalink from admin panel, wordpress says successfully updated, but link to post doesn't work..

    pls help guys

  2. pachrang
    Member
    Posted 4 years ago #

    apart from posts, even about page, monthly archive page also doesn't work... pls help

  3. Zulfikar Nore
    Member
    Posted 4 years ago #

    Did you creat that .htaccess yourself or did wordpress creat it when your changed thepermalinks?

    And are you on a windows server? if you then the mod_rewrites wont work that way as windows works differentky to the linux based servers on mods.

  4. pachrang
    Member
    Posted 4 years ago #

    actually... this is my second installlation for same domain. during my first installation, for some reason, XML sitemap was not generating and then i cleared everything, deleted domain, recreated domain, installled wordpress again

    during my first installation, these permalinks were working and hence i had the copy of the .htaccess file

    and same file i've uploaded to my new installation

    blog is on windows server.

  5. pachrang
    Member
    Posted 4 years ago #

    i checked that my windows server was not configured to php 5.0 so i did it

    but it was still not working...

    then i changed permalink to /index.php/%year%/%monthnum%/%postname%/

    and it worked :)

    but this one still not working /%year%/%monthnum%/%postname%/

  6. Zulfikar Nore
    Member
    Posted 4 years ago #

    but this one still not working /%year%/%monthnum%/%postname%/

    Wont work unless you have url_rewrite installed and enabled as well as having a web.confing with the re-write rules in your installation folder.

  7. jiltin
    Member
    Posted 4 years ago #

    I had similar issue with 2.8.2 permalinks. I could not make it work with other permalinks except "/index.php/%category%/%postname%/". You can try once whether this is working or not.

  8. Kailash
    Member
    Posted 4 years ago #

    but this one still not working /%year%/%monthnum%/%postname%/

    You can use above permalink if you have Apache mod_rewrite enabled. If you have IIS 7, you can follow the steps for "Permalinks without mod_rewrite" from the following link:

    http://codex.wordpress.org/Using_Permalinks

  9. pachrang
    Member
    Posted 4 years ago #

    thanks guys for your help... but unfortunately my hosting provider doesn't have mod_rewrite enabled :(

  10. VivBounty
    Member
    Posted 3 years ago #

    I have also been battling with this issue for weeks and finally, adding /index.php in front of my permalink, /%postname%/ has worked for me.

    I am now using WordPress 3.0 and no more error 404 glitches when I try to use pretty permalinks.

    Thank you so much for you help, guys.

    Happy Blogging!

    VivBounty

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.