WordPress.org

Ready to get started?Download WordPress

Forums

Permalinks not working (9 posts)

  1. pf69.com
    Member
    Posted 6 years ago #

    So I have made a FRESH install of WordPress to start an ADULT BLOG on http://www.pukkabdsm.com/
    the problem is that when I use the the Permalinks with the following settings:
    Custom Structure: /%category%/%postname%/
    Category base: /%category%
    Category pages: /%category%

    .htaccess file:
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    the Permalinks work fine for the MAIN CATEGORIES (ex: http://www.pukkabdsm.com/general-bdsm-info/
    http://www.pukkabdsm.com/bdsm-porn/ )
    but when trying to reach the SLAVE CATEGORIES I get redirected to the INDEX OF THE SITE.
    when I try to reach the post pages I get redirected to the INDEX OF THE SITE (I was getting 404 errors before).

    when I do a search : http://www.pukkabdsm.com/?s=BDSM
    I get the proper results page, but then I click the links, the DON'T open as they should (I get the same errors I already mentioned)

    I have tried lots of other configurations on the settings for the permalinks, but none solved all the issues, with this setting I made the NAVIGATION WORK...

    thanks in advanced for the support!

  2. pf69.com
    Member
    Posted 6 years ago #

    can any one help me solve this issues I am having (and as far as I have seen lots of other people are having similar issues)

  3. iridiax
    Member
    Posted 6 years ago #

    I think that your Category base and Category pages (I haven't seen this one before) values may be incorrect. You may need to have a static value for this field like the word topics or leave it blank so that the default category is used.

  4. pf69.com
    Member
    Posted 6 years ago #

    I will give it a try, and see what happens!!
    thanks for the ideas!!

  5. pf69.com
    Member
    Posted 6 years ago #

    that doesn't work either!

  6. pf69.com
    Member
    Posted 6 years ago #

    any other ideas that might work?

  7. pf69.com
    Member
    Posted 6 years ago #

    any one has a solution for this problem yet?

  8. moshu
    Member
    Posted 6 years ago #

    Category base: /%category%
    Wrong. It should be only category - no % around! Or any other word but NOT a permalink structure tag...

    There is no such animal in WP as "Category pages:"

  9. pf69.com
    Member
    Posted 5 years ago #

    There is no such animal in WP as "Category pages:"

    have you ever been to the ADVANCED "tab" on the Permalinks page?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.