WordPress.org

Ready to get started?Download WordPress

Forums

NextCellent Gallery - NextGEN Legacy
[resolved] Permalinks not holding (3 posts)

  1. kmicheal
    Member
    Posted 2 months ago #

    I am using v 1.9.18 of Nextcellent and I am finding that the permalinks for galleries are not 'holding'. I have to go to Permalinks in the WordPress Settings and press 'Save Changes' for them to start working again. They seem to work for a while and then when I come back to the site the next day, say, they don't work any longer. I have 'Recreated URLs' a few times in Nextcellent's settings, but this doesn't bring a permanent solution. Permalinks for regular WordPress pages are fine, it's just any permalink that starts with 'nggallery'. (it redirects to a 404 page when I try to access a gallery).

    I thought it might have something to do with my .htaccess file's permissions. (I use iThemes Security but have the file set to 664 rather than the more stringent 444), but even if I set it to 775, I still have to re-save the Permalinks in WordPress to get them to work again.

    Is there anything else I can try or is anyone else having this problem?

    https://wordpress.org/plugins/nextcellent-gallery-nextgen-legacy/

  2. kmicheal
    Member
    Posted 1 month ago #

    This is just a response to say this was resolved. After trying all sorts of things I did the ol' 'turn off all plugins' and the problem seems to be solved by having WordFence turned off. I did some searches for WordFence and 'permalinks' but I've not found anything specific, but clearly there is a conflict between WordFence and the URLs which are used when trying to display a gallery on an album page.

  3. WPReady
    Member
    Plugin Author

    Posted 1 month ago #

    Hi kmicheal,
    thanks for your comments and effort to enlight the problem.
    Since I'm user of Wordfence myself, I'll try to dig a little into this problem to find out what's happening.

Reply

You must log in to post.

About this Plugin

About this Topic